Select and Delete rows

  • 18 January 2021
  • 20 replies
  • 990 views

I think, somehow I added three rows to our shared calendar.  No idea how, I was adding lines from/to dependent actions.

  1. I want to delete the rows, I think, but when I attempt to select the rows the entire calendar moves.
  2. I’m assuming I need to unlock something. I’ve found 3 options to unlock, and have selected each of them.  None has allowed me to select anything.  I’m also concerned that just selecting random unlocks is helping to stabilize our calendar, but have no idea what they do
  3. What do I need to do to remove the additional rows?
  4. What do the various Lock/Unlock options actually do?

20 replies

Userlevel 7
Badge +14

@Patrick Cannon -

It might help the community respond if you could confirm which Miro template you are using for the shared calendar.

Kiron

I didn’t create the calendar, I believe Product Roadmap.

What difference does the template make in regards to editing a grid?

 

Userlevel 7
Badge +14

@Patrick Cannon -

It’s important to understand what objects were used to make up the calendar. For example, if it was the table widget instead of the grid, different rules would apply.

If it is a grid and if the grid is not locked then when you hover over the edges of the grid object (near a row or column) you should see a grey “...” button popup. When you click on it, you’ll get a toolbar which will include the trash can icon for deleting the row or column.

You can’t lock individual rows or columns in a grid - the lock/unlock function applies to the grid as a whole.

Kiron

Best answer I can give is its a grid overlay, looks like a table.

When I hover near the edges of the grid, absolutely nothing happens.

If I right click off the grid, I receive a dropdown

Paste
Unlock All

Add text
Add sticky note
Set start view
Set current view as start

Navigation mode
Snap objects (checked)
Show grid (checked)

Show All

Userlevel 7
Badge +14

@Patrick Cannon -

Those options are part of the generic context menu you get when you are clicking in “empty” space on a Miro board.

If you click a cell in the grid for one of the rows or columns you wish to delete such that it becomes greyed out, then click on the “...” menu in the toolbar which pops up there are options to delete the row or column that cell belongs to (see below).

Kiron

 

When I attempt to right click the cell, I receive a dropdown

Edit
Copy style
Paste style
Add comment
Copy link
.....
Delete

I do not receive the toolbar you indicated. I attempted to select Delete and nothing happened that I could see. I did select undo arrow just in case.

Userlevel 7
Badge +14

@Patrick Cannon -

It might help if you include a screenshot of what you are seeing when you click on any cell in the table. Miro also has a table object which might be what that calendar is based on - that object has much less functionality than the grid object but does still provide the ability to delete rows or columns. 

This is what the old table object’s menu looked like:

Kiron

Sorry, the 6 cells on the LEFT, not right.

I can’t tell if my submissions are being sent, I added an image, selected send but see no indication my reply was actually submitted.

Is there anything special I need to do to send images?

 

You are correct, when I right click, I receive the dropdown in your response above.

Odd experience, I was in Miro reviewing sticky notes, not trying to make any changes.  When I expanded the calendar I saw that 3 additional rows had been added.  When I selected Undo symbol they disappeared.  I have no idea how reviewing sticky’s added rows.  I’m becoming very frustrated with this tool.  :)

Userlevel 7
Badge +14

@Patrick Cannon -

Assuming the calendar is using the old Table object, then when you click on the Edit button (which you can see in my screenshot), it will enable you to edit the table in a separate, dedicated view. Select the full row which you wish to delete and click the trashcan icon to delete it.

Kiron

 

I right clicked, and did not receive the expected dropdown, so I closed my Miro connection and then reopened IE.  When I opened Miro the entire calendar has now moved from where it was originally, and some of the sticky’s moved somewhere else.  It’s a complete mess, and I had no idea what closing and reopening the tool would do.

I’m going to leave it alone for a while, I can’t afford to do any more damage.  I have no idea how this tool works, or doesn’t work, and it just doesn’t seem the least bit logical.

Let me ask this another way, I believe I’m incorrect that I need to delete anything.  Look at the image below, I believe I lengthened the cells, and I need to compress them to resolve the issue, see image.  When I select unlock, I’m able to move the entire grid, but can’t affect individual cells.  Does that make more sense?

 

Userlevel 7
Badge +14

@Patrick Cannon -

I can’t see any way to change the width or height of a column or row using the old table object, so I’ve got to assume that this is a grid of some kind.

Is there any type of label just above the top left of the overall table which might help confirm that it is, in fact, a grid? If it is a grid there would also be a “Send feedback” link at the bottom right as you can see in my example below.

 

Fixed it, with the help of another employee.

  1. When she right clicked the drop down had an option of unlock
  2. She then zoomed in to about 250%
  3. When she moved her curser to a line in the grid, her curser changed to the double line, like Excel, which allowed her to move the line and compress the box.
  4. I’ve tried what she did myself
  5. When I right clicked, I received a dialog dropdown which didn’t include a unlock option, but was able to select Edit which opened the dialog you sent originally
  6. When I selected the elipse …
  7. The dropdown in your second image appeared and allowed me to select unlock
  8. It’s really odd, I receive different right click options depending on how long Miro is open.
  9. I think expanding the screen to 250% seems to have made the option to move the lines become visible.
  10. Thanks for all your help
     

Kiron, I really appreciated all of your feedback, thank you

Bottom line

  1. The grid unlocks if you hold the cursor button down to long.
  2. Patience is the key, actions are delayed.  If I’ve accidentally unlocked the grid and move my mouse, the result may take up to 10 seconds to actually appear.  I move fast, login, make updates, log out.  I may not even see that I moved the entire grid.
  3. I need to constantly right click outside the grid to verify I haven’t unlocked the grid.
  4. Someone on my team shifted multiple grids around, it took me an hour, but I was able to put it back together. 
  5.  
  6. Feedback for the MIRO TEAM
  7. I would suggest that unlocking the Grid be an obvious decision, not something that can happen accidentally. Remove the feature that allows one to unlock the grid by holding the cursor too long.
Badge

I’m having the same kind of problem. Somehow extra columns and rows were added to my table, which I didn’t want or intentionally do. I can’t select rows or columns in my table to delete them. It’s a big waste of time. I’m really missing MS Office right now.

Userlevel 7
Badge +14

@Monica (she/her) -

What do you see when you click on a cell and bring up the “…” menu? Do you not have the options below? Is it possible the table is locked and just needs to be unlocked?

Kiron

Badge

Thanks for your help. I finally figured out how to do what I needed to do, but it was a frustrating waste of time in a busy day.

Reply