Shameless plug for my new Miro plugin CarbonCopy

Userlevel 4
Badge +3

Welcome to this promotional post for my plugin: Carbon Copy.

The plugin lets you update an idea in one place and sync the idea across widgets everywhere on a Miro board. Give it a try and let me know what you think, how you use it and whether it inspires new ideas. Just share your feedback, it’s all welcome.

This is a personal project, I’m doing it for fun. I will implement some improvements over a few months, if you come across bugs or problems I will fix them more quickly.

Just @mention me in your posts here on the forum, or reply to this message.

40 replies



I am considering adding Carbon Copy to Miro. I was curious if anyone has used carbon copy alongside of Jira integration. Did any onc experience any issues such as duplicate records in Jira, etc? I am just looking to see what other’s experiences were like. Any information helps! Thanks. 

It’s not working for me! The CarbonCopy UI has the Sync button grayed out - even after selecting things on the Miro board, as you do in the youtube video.

I’m using Miro’s “New UI”, by the way.

Edit: Ah, I seem to have narrowed down what is causing the bug. It doesn’t work on the “Database” shape within More Shapes (the cylinder).

@Markus Smet, could you please share a link to the privacy policy? Thank you in advance!

Userlevel 4
Badge +3

Here you go.

@Markus Smet, thanks for sharing and really a great plugin! Just one question, do you think you could add the functionality of multiple boards? eg. Board 1 has post and board 2 to has the synched post it? 

Thanks again!


Danny van Kent


agree this would be a super useful feature. Use case is:

  • we work with multiple boards internally as we design features
  • towards clients we have 1 board per client where we discuss/centralize finished features
  • currently we CUT(not copy)/paste from the internal board to the external board (to avoid multiple versions), but sometimes we want to keep it internally as well as we continue to futher enhance it
Userlevel 7
Badge +7

@Markus Smet Just wanted to say I love Carbon Copy! Let us know if you have a Ko-fi or Patreon so we can buy you a coffee as a proper thank you for creating and maintaining this amazing app. :innocent::coffee:

HI! @Markus Smet ! I love the promise of this plug in, and look forward to future versions. It didn’t quite work for what I wanted yet. 


The issue is I can’t uninstall it. I can’t find where on the board I had some Carbon copy items, so can’t delete/remove the CC functionality. Now all 20 people at my company keep getting asked to install it… and they are not so happy. 

How can I remove it so no one is notified any more? i saw your post about user v team permissions, and it doesn’t look like that is ready yet. 


For now, I have another Miro account I can do testing on, I need this completely gone from my company board, please!!

@Markus Smet -- Hi! Are you able to respond to this please?

Userlevel 7
Badge +7

@Jenny Tarwater Have you checked Team Settings -> Apps & Integrations? Just select the app in the Apps & Integrations settings and then click Uninstall for team.

@Markus Smet -- so, similar to Jenny above, we have some users in our team who like and want to use CarbonCopy. However, our team is orders of magnitude larger than Jenny’s, and we have now entered into a ping-pong game of uninstall for team (user annoyed by repeated auth requests) <> re-install (user wanting CC).  So, what’s the horizon on getting the app installed for individual users you mention above? Otherwise, would refresh tokens be a possibility, (see

Hello @Markus Smet , thank you for this great app! I have used it on my personal Miro boards and I really like its potential. I am trying to use it at work, but I am struggling. 

At first the app didn’t show at all in my work Miro because it wasn’t approved by my company’s security team. Now it is approved by the security team and I can now see it when I search for it. I authorized and installed it, and got the “App has been installed” banner, but I am not able to actually use it.

Have you heard of anyone having this sort of issue and know of a potential solution?

I uninstalled the app from Settings so that I could replicate what I did and take screenshots this time to show you. Below are the screenshots of what I did in sequence:

note: I highlighted the title of the dialog for some reason ‘:)
I get the “App has been installed” black banner
I tried to drag the App to the left toolbar but I was not able to do so.

So I tried again to install it:

now the button says “Reinstall”
I again get the “App has been installed” black banner
But I still cannot drag the app to the left tool bar and use it :(

Have you heard of anyone having this sort of issue and know of a potential solution?

Thank you in advance!

Userlevel 4
Badge +3

Thanks everyone for your comments and questions.

I’m not actively developing the app so it has to be taken as is. If you are not sure, I would suggest installing it on a trial and checking whether the features fit what you need.

Please bear in mind that you must run this plugin in the browser for it to work, this is because I have to store reference data outside Miro to maintain sync’s between board widgets (e.g. post-it notes). So if you use the Miro desktop app remember Carbon Copy won’t work.

I will consider whether it’s worthwhile updating CarbonCopy to the new API. If someone is interested in taking the product idea forward I can also consider opening it up so anyone can contribute.

@Markus Smet , thanks for the reply! 
I actually have the exact same problem when trying to use the Carbon Copy app in a browser (Chrome). But I understand that you are no longer developing it and we need to take the app as is 👍

Thanks again and I hope you have a great day :)

Userlevel 7
Badge +7

@Markus Smet Opening it so anyone can contribute sounds like a great idea. Open source ftw! 😀

Userlevel 1
Badge +1

Hey, is the tool somehow still available?

The website page says it cannot find it in the marketplace?