Undo (CTRL+Z) undos twice every time i try to undo once

  • 29 March 2024
  • 5 replies

I’ve been using Miro for a long time but I think since the latest Firefox update 124.0.1, Miro suddenly started to undo twice when i click on CTRL+Z once. I tested other boards and checked if the problem is with CTRL+Z itself with me but everything works fine elsewhere but here.

It is not Firefox as I’ve tried with several other tests and they all seem to be working fine so something is wrong elsewhere and this is a big deal for me as I can’t properly use the board now and I really don’t want to switch from Miro.

5 replies

Userlevel 7
Badge +12

@vemic - I just tested from the same version Firefox (64-bit, Windows 11) and both the Ctrl-Z and Undo action from the left toolbar in the the Miro UI.

For this first test, I

  • press the N key to quickly create a new sticky note
  • Next, while still in edit mode, I type the word test. I then click on the board canvas to get out of edit mode on the sticky note.
  • Finally, I press Ctrl-Z once, which undoes the word “test” and then I press Ctrl-Z again to undo the creation of the sticky note.


And in this test, I add one more word in the sticky note (a third action), and then I use the Undo action in the Miro board which undoes all three actions with three undos.


Have you tried

  • disabling any browser extensions?
  • Clearing your cache? 
  • If you are on a laptop, and currently using an external keyboard, have you tried using the laptop keyboard only?

@Robert Johnson The issue is still persisting after disabling extensions and clearing cache. I unfortunately am not using a laptop but the keyboard seems fine with other boards. The undo button on the left panel works fine but CTRL+Z still undos twice (I’ve tried with a pen and drawing 2 lines and pressing CTRL+Z once removed both lines)

I tried the sticky note too and it removes both the text and the note. I am not sure where the issue may be if it works for you but not with me.

I suddenly am running into this too!

IPAD Pro, Miro app, Touching the CTRL button just does whatever last action i did.

If i last duplicated, touching ctrl duplicates again

if i last hit undo, then every time you press ctrl it undoes.

Ill try to find out where we have support and report it as a bug I guess.

Same issue here on thé iPad app, cmd button is undoing without pressing z. I can’t use any shortcut.

same issue on ipad as above — absolutely strange behavior.