[RESOLVED] An issue with logging in on desktop app with Google account

Show first post

46 replies

@ASEEM MAHAJAN Thanks for the work around - that worked.

Having the same problem. Really problematic, this is a key feature for me

Same error on Mac

Userlevel 7
Badge +5

Oh sorry to hear this!

I’ll check in with the team again, and will keep you updated here.

Tips to the developers: I’ve encountered this in my own app, and it can be solved by sending different UserAgent header. Not sure if that’s a great solution though :D 

Hey all!! 

I've just tried it via Microsoft Office 365 with my Gmail and it definitely works! :) 

Nell L.

Same problem here. Everytime I try to log in via Mac Desktop App for miro by “Login with google Account”.

Userlevel 1

Mac also has the same error. I think your tech team should review your OAuth protocol implementation in desktop app.

I’m having this issue too, cannot sign in to Miro desktop on Mac using google. 16 February 2021.

Userlevel 7
Badge +5

Hello everyone,

The issue with Google Authorization in the Miro Desktop App was fixed in version 0.4.8. The application should notify you about the update, or you can manually download the latest version here

Could you please check if you can successfully authorize via Google OAuth now? 


Important: if you use two-factor authentication, the issue might still be there. The development team is on the case as well. At this time I don't have an estimated release date but we will let you know when we receive more information. As a workaround, we suggest using Miro in a browser until the fix is complete as within the browser you should be able to log in with SSO and two-factor authentication without any issues.

1 year later. I still face this issue.

On Windows; most recent release downloaded and tested. It kept me from logging in the past, i thought something was wrong on my end and didn’t bother. I’d always liked the workflow on Miro, so I had it in the back of my mind and wanted to finally try it again today. 

And, “We suggest using Miro in a browser until the fix is complete” is not a valid response from a team. You cannot suggest the user use a different platform than their preferred one when it is clearly offered for it and compatible on it. 

You maybe quietly losing new users. Beware.

There should be a workaround like Figma to send the user to log in using the browser and send a handshake back to the application. This would solve it so easily. It’s sad to see a company with such a bright product falling through the cracks - seeing how you have not investigated a solution to the issue your users are facing for about a year now.

I still hope you fix this soon. I still enjoy the app and the functionality. I’ll try again when I can.

I will send a support ticket as well.

Thank you.




Facing the problem today 2021-12-15.

On Windows 11 and latest version of Chrome.

Having this issue on the desktop app, with the latest version

Same here

I’m using 0.7.1 on Windows 10.


Just now downloaded the app on Mac, but same issue.



Same here. Just cannot login, even though I've reinstalled the app on my Mac. Unfortunately desktop version is my prefered one, so if there is no workaround reasonably fast, I will switch to Figma, where the rest of my team and majority of my friens already are. And everyone is asking me, what the hell I'm still doing with Miro. I always replied, that I like Miro much more, but with this issue, which is critical, my patience will probably expire...

Same here. I can't log in into the app on a Mac. It gets stuck at the 2 steps verification….

I can’t log in with google account on Mac app. When I enter my google account, I get an error: 

“Couldn't sign you in. This browser or app may not be secure.

Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.”



No, this has NOT been resolved. I still get the same error to this day with the Mac app.

Any ETA on this being resolved? Issue still present on Mac desktop app

Just an FYI: I experienced this issue still with the newest download. When I tried quitting the program, then trying again, it worked. <shrug>

Feb 2022.  Had to reset a window 10 (edition pro 64 bit) on a lenovo machine.  My miro account is setup using google authentication.  Experienced the long running google security error ~ “browser might not be secure”.  Tried both the windows store install and the default windows desktop install direct from the miro.com. 

Solution for me was to uninstall miro using the windows app uninstall then took a fresh download of the enterprise msi (64 bit for me) and it worked with google two factor authentication without error.  Its in a link above the desktop install options.