Sketch Miro Problem eoor during syncing after upgrading to Sketch 87.1


I had an existing Sketch file which was working fine when we used the Miro plugin it sync the artboard to Miro. 

We could work without issue, update the artboard on the Sketch file and then resync to miro
This would then replace any existing instance with the update art board

We upgraded to Sketch 87.1.

Now if we try an resync it to the Miro board we get an error

“An error occured.
There was an error during syncing. Please Try again”

If we create new artboard in the doc and sync that it works as expected. Plus we can update and resync without issue.


11 replies

Userlevel 5

Hey Mark - sorry to hear this happened

A question - if you duplicate the file and sync it for the first time (again), do the resyncs start working again?


@Addison Schultz  - It’s a cloud based file - how dow I duplicate it in the cloud? 

Userlevel 5

Ah, that’s a good one - Are you able to download it?


Downloaded a local copy and tried again - same result

Still get the 

““An error occured.
There was an error during syncing. Please Try again””


Even If I try remove everything from the artboard - so it is just blank - I still get the same generic error message 



Found a possible issue - where one of the symbols had a complex SVG - removing that seems to allow us to export up to Miro again.

However syncing from Sketch to Miro seems upload a new version of the art board and not replace the old versions on Miro

Userlevel 5

Thanks again Mark, I’ve also passed this over to the team working on this

I have the same error here… @Addison Schultz  do you have any updates ? Thanks!


@Josianne - as Seen above @Addison Schultz said it is a bug and they are looking into it. 

Ive done some preliminary testing and it seems like new art boards are fine - not older ones

Userlevel 5

Hi @Mark McIntyre @Josianne, This issue should be fixed from the team!

@Addison Schultz It works now but, When I sync board that was already on Miro (place in particularly order, the new boards doesn’t take the same emplacement and I have to replace all of them now… They just appear in one row…