What to do when iFrame embed just spins...

  • 7 September 2020
  • 5 replies
  • 621 views

Hi.

I’ve been hunting for a project management setup (hard) for a long time and I think I could do it with a few tools on a Miro board and a few other things embedded. I’m trying to embed views from a tool called clickup; I get the code and apply via the iFrame embed. The ClickUp logo shows but it just ‘waits’ forever.  

 

Suggestions?

 

Thanks in advance and be well.

 

Dan


5 replies

Userlevel 7
Badge +12

Hi @Dan Sullivan  I had never heard of ClickUp until now, so i just signed up for a free account, created a Task Management board, clicked the Share button, grabbed the embed code, and pasted it into a Miro board in my Consultant Plan and I see the following:

 

I noticed the Sign in link, so I clicked it and then got an error that “ClickUp failed to connect”so I clicked off of the embed window and loaded it again and see that I am now logged in:

 

But when I tried to interact with the ClickUp iframe window, it switches over to:

 

I also noticed that when I was just going through the sign up process and selecting my first template, it keep timing out. I suspect that ClickUp could be experiencing issues right now. Have you reached out to their support team? Are you able to successfully embed the same iframe code into another site?

Thanks @Robert Johnson . I didn’t get to the sign in page before and there are multiple views in ClickUp that ‘can’ embed. When I try to embed the Kanban, it shows the content (good!) but I can’t change the aspect ratio. If I can fix the aspect, and make it ‘live’ (vs. having to click it), I may continue.

 

Alternatively, I’m also trying to embed the other way around (Miro into ClickUp). That’s not working either. https://community.miro.com/got-a-question-ask-the-community-45/embedded-boards-show-hand-finger-icon-until-click-1227?postid=7803#post7803

 

Not my day today :)

Userlevel 7
Badge +12

@Dan Sullivan - You should be able to modify the width and height in the ClickUp HTML embed code and the Miro board should respect it.

The following were the default values in my ClickUp embed HTML:

 width="100%" height="700px"

I updated the width to 1000px like so:

 width="1000px" height="700px"

And now it does embed with those dimensions:

I am only speculating here, but maybe Miro doesn’t automatically load externally embedded content is to avoid reduced board performance. This may also be a deliberate way to ensure that it was the user who took the action of loading an external URL.

Userlevel 7
Badge +12

@Dan Sullivan This was just posted 8 hours ago - I'm guessing that it was already in place when you were testing yesterday:

https://community.miro.com/changelog-discussion-31/new-integrations-and-atlassian-security-self-assessment-1915

Userlevel 7
Badge +5

Hey @Dan Sullivan,

If you still have issues with this iFrame embed, I’d suggest reaching out to the Support team directly - https://help.miro.com/hc/en-us/requests/new?referer=community

Reply