Thumb wheel (horizontal scroll) on Logi MX Master 3 mouse not working in desktop app

  • 15 November 2021
  • 10 replies

Userlevel 1

Hi there,

I have a Logitech MX Master 3 mouse. If I use Miro in a web browser, the additional thumb-wheel works perfectly for horizontal scrolling, but on the Windows desktop app it doesn’t do anything. The normal mouse wheel at the top works for vertical scroll on both, and Mac dekstop app is fine.

Anyone else seen this / know a fix?



10 replies

Userlevel 7
Badge +6

@Mike Taylor -

I’d suggest opening a support request with Miro given that this is a very specific system configuration issue: Submit a request – Miro Support & Help Center


I’m facing the same issue @Mike Taylor 

I am having the same mouse and the same issue 


Userlevel 7
Badge +12

@Mike Taylor, @Philippy Gonzales, @Clement Farah  - Has anyone opened a Miro support ticket using the link that @Kiron Bondale provided?

If so, can you share what the Miro support team told you?

Userlevel 1

Hi Robert - yes, support recommended reinstalling the Miro app, and checking that the Logitech drivers were up to date. It didn’t help - but I also notice the same behaviour with the Figma desktop app, so I suspect it’s a Logitech issue rather than a Miro-specific one. In the meantime, I’m just using the space bar + drag technique to move around the canvas.

the same mouse ( Logitech MX Master 3) is also used on mac, and it works perfectly in miro for mac. 

if Miro app shares the same code for mac and windows, then i, think the issue is windows/ drivers problem. 

@Robert Johnson The miro support team recommended to change in the Settings the Mouse or trackpad option. Works for me but sometimes, I don’t know why, stop to work.

Tried to change the settings to “mouse”, but now the thumb wheel zoom in/out …

But reverting the configuration to “Auto” allowed for the horizontal scroll to work  😍

Massimiliano Franco's solution didn't work for me. Is there no solution yet? I even tried setting it up directly for Miro with Logi Options but nope. What I do notice is that it recognises the horizontal scroll for 1 second and then nothing. 

I'm experiencing the same issue with my Logitech MX Master 3 mouse. Massimiliano Franco's solution didn't help me either. I attempted setting it up via Logi Options specifically for Miro, but no luck. It briefly recognizes horizontal scroll, then stops. Frustrating, right?