[RESOLVED] Miro doesn't work on Mac (M1) - grey screen

Userlevel 2

Miro app on mac isn’t working today. If I sign in my account on the website, it works. Is it a bug? How can I fix it? I’ve tried re-installation and clearing cache, but nothing works.

Alyona 1 year ago

Hey everyone, 

The fix for this bug was indeed released in version 0.7.14, you should be prompted to update the app upon launch, but can also download the new version from our website. Please note that you might notice some slowness when it comes to the app's performance, it will be addressed in the next version. Thank you all for your patience!

View original

28 replies

0.7.13 breaks it for me, any solution or fix? any chance to get to earlier version?

same here, it stop working today on my M1 mac

Userlevel 6
Badge +1

Hey @AnnaKamaldinova, @Marc Hagemann

Alyona from the Miro Support team is here 👋

Our team is looking into this right now, so hopefully, the bug gets fixed soon 🛠 I'll let you know once we have any updates. Please bear with us! 

Version 0.7.13 for Mac for M1

Since today (may 19, 2022) stopped working. I can see only grey board in app.

I tried reset application data and reinstall App. Nothing helped.


Userlevel 6
Badge +1

Hey @David Tuganov,

I moved your comment here as this is the thread about the current bug. The team is already investigating this issue. Once a fix is available - I'll be sure to update everyone in this thread. 

My desktop app was working perfectly and now it is just a grey screen, can’t access any boards. I have tried:

  • restarting Miro & my computer multiple times
  • uninstalling & reinstalling
  • refreshing current tab
  • reset application data
  • hardware acceleration on & off

I am on a 2021 Macbook Pro. It is working fine on the browser version.


Any help please! Have run out of ideas and exhausted options on the existing help portals.



To add, I am on version 0.7.13.  & Mac OS Monterey 12.3.1

Having exactly the same issue as mentioned above and have tried all troubleshooting. I’m on Miro version 0.7.13 on Mac OS monterey.

Anyone find a fix?

Same here:

  • Miro Desktop App 0.7.13
  • Macbook Pro (M1) 2021
  • Mac OS Monterey 12.3.1
  • works fine in the browser

I tried re-installing, reset application data, … nothing


Miro Desktop App 0.7.13, Macbook Pro 2021 (M1), Mac OS Monterey 12.3.1

Since this afternoon, the Miro app (Mac M1 Version – 0.7.13) no longer loads the data. All measures, including uninstalling and reinstalling, have had no effect.

But the Intel version (0.7.13) runs on my Mac Mini M1 / Monterey 12.3.1 ...

Userlevel 6
Badge +1

Hey @ABohmer, @Oedel, @Stefan Degen,

Moved your reports here too. The team is working on the fix already. Please bear with us!    

I got the exact same problem all of a sudden @ around 9AM GMT-5

Running on my macOS BigSur 11.5.2 with M1 Chipset with Miro version 0.7.13

Same gray screen issue others are having, same Mac M1 setup.

+1 same same on an M1 mac only getting gray screens. Thankfully browser version working, but I had a moment of “Eek!”

Same grey screen. Monterey 12.2.1 Miro 0.7.13

Hello community,


my miro board is coming up grey as I open the app (miro M1 app) I have refreshed the board, restarted the app and reinstalled the app. Doing all of this did not fix the issue so having to resort to opening alot of tabs on chrome.

Does anyone know how this can be fixed?




Hello Vishal, I created an issue something like 4 hours ago, I received an automatic acknowledgement of an issue but as you can see up to now nothing changed. The Miro status page dose not show any issue.
Best PB

I have tried clearing the app cache and following the instructions to clear out the app settings folder and still I cannot get anything but a gray screen for the “boards” tab. 

Anyone else run into this and have a fix? Works fine on another M1 Mac. 

I have the same issue here, yesterday was working fine, but today just the grey screen. 

probably is better to wait until tomorrow. 


@Nuno Mota you can use the web version, you should be fine.


As of this morning when I tried to pen the desktop app all I see is a solid grayed out block.


I have tried restarting, uninstalling and reinstalling fresh download, etc and no luck. Does anyone have ideas of suggestions on what might be causing this. It was working fine yesterday and have not done any major systems updates or anything since then.

I am on a Mackbook Air M1 in case helpful.

Thanks in advance for any insights anyone can offer.



I have the exact same issue. Have re-installed, reset cache and it won’t work on the M1 iMac either. 

Works fine on iOS iPad, browsers but not working on desktop client app Miro 

Same issue here M1 Mac, updated, reset and re-downloaded. Nothing works on Mac OS. All works on other iOS and web browsers.

Checking in for my org--we found out all of our M1 macs aren’t playing nicely with v 0.7.13 - reinstall, cache clean, etc not working while web version is a-OK


Found this interesting tidbit in the logs--it looks like the update couldnt write to the /var/ folder:


2022-05-19 09:29:08.332 ShipIt[81862:14684106] Beginning installation
2022-05-19 09:29:11.348 ShipIt[81862:14678481] Moved bundle from file:///Applications/Miro.app/ to file:///var/folders/2h/ynst65x112j5yg_pf0nxndc40000gn/T/com.electron.realtimeboard.ShipIt.C7YAhfnp/Miro.app
2022-05-19 09:29:11.348 ShipIt[81862:14678481] Moved bundle from file:///var/folders/2h/ynst65x112j5yg_pf0nxndc40000gn/T/com.electron.realtimeboard.ShipIt.ehqB4AnC/Miro.app to file:///Applications/Miro.app/
2022-05-19 09:29:11.449 ShipIt[81862:14678481] Couldn't remove owned bundle at location file:///var/folders/2h/ynst65x112j5yg_pf0nxndc40000gn/T/com.electron.realtimeboard.ShipIt.ehqB4AnC/Miro.app, error NSError { domain: NSCocoaErrorDomain, code: 4, description: "“Miro.app” couldn’t be removed.", failureReason: "The file doesn’t exist.", underlying error: NSError { domain: NSPOSIXErrorDomain, code: 2, description: "The operation couldn’t be completed. No such file or directory" }, userInfo: {
    NSFilePath = "/var/folders/2h/ynst65x112j5yg_pf0nxndc40000gn/T/com.electron.realtimeboard.ShipIt.ehqB4AnC/Miro.app";
    NSUserStringVariant =     (
} }
2022-05-19 09:29:11.802 ShipIt[81862:14678481] Installation completed successfully
2022-05-19 09:29:11.804 ShipIt[81862:14678481] ShipIt quitting

Just got the v 0.7.14 update and we are back in business! Thanks for the quick fix, Miro!