Answered

Inviting Non-Team Users to Boards

  • 12 August 2020
  • 2 replies
  • 1928 views

I am trying to invite external collaborators to a board that I do not want to provide a public link for. A few days ago, I was able to send e-mail invitations to users outside of my license, and when they accepted, they displayed in my Active Users section as “non-team users” with Occasional licenses. Here’s a screenshot:

Now, when I try to invite external collaborators to the same board, I get the following error message:

 

It seems to be forcing me to invite users as members of my team, and no longer allows them to be Occasional Non-Team Users. Why is this happening all of a sudden?

icon

Best answer by Robert Johnson 12 August 2020, 23:02

View original

2 replies

Userlevel 7
Badge +12

@Keirstin Townsend If they were showing up as Occasional users, then they would have been consuming a Day pass, which costs $3 per 24 hours that they access the board. The fact that you can no longer add them that way leads me to believe that your plan administrator has since disabled Day passes - I have mine turned off as follows:

Here’s a full breakdown of all Plans and Features.

So, what can you do now? Well, Miro has started rolling out Password protection for Publicly shared link (see screenshots of this in my post).

You could

  1. Enable Guest Editor access for each board you want to share with non-team member collaborators - if you don’t have the Set password option now, you can go back and set one once the feature is enabled on your account.
  2. You then share the URL and password with your collaborators.
  3. Then, so they can easily get back to the board, have then “star” it by clicking the star icon the right of the board name. Now when they come back to their Miro dashboard, they can click on “Starred” and see the board(s) you have shared with them:

 

@Rob Johnson Thanks for the tips. So awesome about the password protection for publicly shared boards. Will keep an eye out for that feature. Day Passes are enabled on our account when I checked, but I did end up getting this issue resolved by adjusting who on our team can invite non-team users in the Permissions section. Thanks for your time!

Reply