I want to wheel zoom in smaller steps, how?

  • 3 February 2021
  • 9 replies
  • 431 views

Userlevel 1
Badge +2

Now when I zoom into project (when editing) by using mouse wheel I get jump between 51% and 143%, this makes it unusable. I need to zoom with more steps in between the 51 and 143 percent. How to configure these steps of zoom?


9 replies

Userlevel 7
Badge +14

@Aladeen -

Interesting question - I set my Windows mouse settings to only move 1 step at a time with the trackwheel and I found that with different Miro boards I was getting different zoom increments ranging from 3-8%. 

My guess is the zoom increments are controlled by the setup of the board itself - perhaps the overall size or dimensions.

@Marina - any chance you could dig up any info on this?

Kiron

Great question! I’ll ask the team and get back to you.

Userlevel 1
Badge +2

Thanks for the response. I might add that I am using Firefox on Ubuntu. It may not suit someone, but it serves me well. When I scroll webpage (eg this thread) I get small steps, the scroll jumps one or two lines at a time.

Userlevel 7
Badge +16

My zoom increment experience is different between Chrome and Firefox (it takes more wheeling to zoom in Firefox).

Userlevel 1
Badge +2

My zoom increment experience is different between Chrome and Firefox (it takes more wheeling to zoom in Firefox).


Hmm, I wonder what is the difference between your settings and mine? I don’t know how much system settings affect behaviour of Firefox. Maybe there is something in Firefox’s “about:config” I could change to make it better.

Hi there,

So the team told me that this is not board-specific and Miro shouldn’t influence it at all.

We also checked this behavior on Ubuntu and it’s okay - 10-11%/mousewheel step.

Badge

I also have a problem with this.

Scrolling the mouse wheel in Chrome takes me from 6% → 26% → 117% - three increments that are too large to be useful and make navigating the board difficult.


I’m using Windows 10, the latest version of Chrome, and I don’t have any special accessibility settings I’m aware of that might influence the scroll wheel behaviour.  Zooming on other web apps works as expected.

 

Zooming on Miro in Firefox also works as expected (increments of ~1%), but I need to use Chrome for my other work so it’s quite inconvenient to have to use a different browser just for Miro.

 

Thanks for your help!

Badge

On windows 10 chrome 89, I zoom out from 100% > 33% with one tick and zoom in from 100%  > 272% > 400%.

This basically makes mouse wheel zooming unusable. 

Other similar products (sketchboard, lucid spark,...) do not have this behaviour at all. 

 

There’s a related request on the miro wish list here : https://community.miro.com/wish-list-32/custom-zoom-percentage-1016 

Badge

The problem is caused by a bug in Firefox v88 - see all details here: https://community.miro.com/ask-the-community-45/known-bug-zoom-on-firefox-v88-doubles-every-time-you-zoom-in-out-4631

Reply