[FIX IN PROGRESS] Can't see all the content (tried Safari, Chrome and desktop app)

Something happened to exactly 1 of my boards. I can`t see my content, although I see on the board map that it`s there. It shows on the map but the navigation is weird and everything seems to be invisible. What is it? I have tried doing it with Safari, Chrome & Mobile app - nothing helps. 


12 replies

Good afternoonBoards no longer appear on all devices.How can I fix this problem?
Many thanks for the help.Best regards, Polina
Userlevel 7
Badge +12

@Anastasia Kadushkina - And have you tried signing out of Miro, clearing your browser cache (or resetting the desktop app data), and then signing back in?

Userlevel 7
Badge +12

Another test t I would be curious about is if you were to set the board's share setting to "Anyone with the link = Can view", and then try opening it from an incognito window, i.e., as a unregistered/anonymous user. 

Another test could be to duplicate the board and see if you are able to view the duplicate. 

I`ve tried duplicating it and it's all the same on the copy board

on the first board where it happened when I tried to save some area as image at first it saved it with content, then it only saved empty space (even though I highlighted the area with content)

on the second board I tried to save it and it saves not totally empty space but shows only frames but no text or anything else (but I know there is text)


Tried copying information from the malfunctioning boards to “healthy” ones & it crashed them in the same way - I pushed “paste” & and it showed the loading bar (pasting content), then it froze for minutes. When I reloaded - another board was in this state((

Hello, the content on my board seems to have disappeared. I used the ‘Map’ view to find the content on the board, and the content appears to be there (see screenshot and viewfinder in bottom right), but I can’t bring the content into view. I can’t seem to adjust the zoom feature either. I have logged out/in again, tried different browser, tried installing the desktop app, tried duplicating the board… nothing has solved it. Can anyone please advise? I’m new to Miro.


Hello Anastasia, did you find a solution? I am having the same issue. 😔

Userlevel 7
Badge +12

@Polina ArtCardinale - I merged your post with this one as the issue appears to be related.

@Anastasia Kadushkina - Since you are on a Free Plan cannot submit a support ticket, but I am able to reproduce the issue, I will convert your post into a support ticket. Once you receive the email confirmation of the ticket, please reply to that email with the same board link that you shared with me via private message.

Also, it would be helpful if you could reply to this post with what the support team tells you 🙏

@KMGS - If you have a paid Miro subscription, you can open a Miro support ticket by following these instructions:

Userlevel 7
Badge +4

Hi @Polina ArtCardinale @Anastasia Kadushkina and @KMGS! Sorry to hear you are experiencing issues with your boards. Can you please share you boardIDs so our team can take a further look into it?

Userlevel 7
Badge +4

Hi @Polina ArtCardinale @Anastasia Kadushkina and @KMGS! Sorry to hear you are experiencing issues with your boards. Can you please share you boardIDs so our team can take a further look into it?

@Polina ArtCardinale @Anastasia Kadushkina @KMGS 

Thank you for your patience while the team had a look at this! I’m happy to inform you that our developers fixed the issue you reported earlier. You should now be able to solve this by reloading your board. Can you please try this to see if everything works as expected Please let us know if that works!

Thank you, everyone, for your help! Earlier today I was told by the support that the developers fixed the issue. I managed to get to my mail and the boards just now - tried reloading and everything finally works. For now all the boards that were “touched” by this bug seem to have fully recovered!