npm run start


Badge +1

this is the first miro app i’ve tried to create, so im following the webinar here - 

 

when i run npm run start  i get the following error, 

 

npm ERR! Missing script: "start"

 

seems like probably a basic error but i’ve not had it before on other solution i’ve developed, any ideas how to resolve it? 


6 replies

Userlevel 2
Badge

Hi @Tom Denby!

Awesome that you’re using the webinar! Could you please share what configuration you used for the project, did you also use ‘Next.js framework with Web SDK and API client installed’ and Typescript? Also it would help a lot if you share the package.json that was generated, so we can see if the ‘start’ script is there. 

Thanks, 

Elena.

Badge +1

Hi @Elena Ignatik ,

 

im use the same config as the webinar - next.js. typescript. 

 

im literally following it step by step

 

Tom

Userlevel 2
Badge

Great, thank you. I double-checked the configuration that you’re using, and everything seems to work as expected, so we can take a closer look at your environment.

Could you please:

  1. Tell us which version of node you’re using
  2. Send the content of the generated package.json file
  3. (just in case) Check that you running npm start from the same folder where package.json is located
Badge +1
  1. v18.16.0
  2. {

      "name": "my-miro-app",

      "version": "0.1.0",

      "license": "MIT",

      "scripts": {

        "build": "next build",

        "start": "next dev",

        "lint": "next lint"

      },

      "dependencies": {

        "next": "^13.0.0",

        "@mirohq/miro-api": "^1.0.2",

        "react": "^18.2.0",

        "react-dom": "^18.2.0",

        "dotenv": "^16.0.3",

        "cookie": "^0.5.0"

      },

      "devDependencies": {

        "@mirohq/websdk-types": "latest",

        "typescript": "4.8.4",

        "@types/node": "^18.8.2",

        "@types/react": "^18.0.24",

        "@types/cookie": "^0.5.1"

      }

     

Userlevel 2
Badge

Thank you, that looks correct, which means that the app generated correct source code, and the problem is most likely local environment. Unfortunately, this is not something we can help with (although if you share a screencast of the actions you’re performing, we or other users of the platform might see familiar patterns). 

Alternatively, you can try using `yarn` followed by `yarn start`, but also make sure that the folder is correct: for example, run `ls | grep package.json` - it should respond with `package.json`. I can see that in the webinar two folders with same name are used, that’s why it can be confusing. 

Badge +1

i seem to fix it by installing next.js again.

 

npm i next. 

 

thanks for all your help. 

Reply