Normal team board not able to integrate into my website using API

  • 4 November 2022
  • 9 replies
  • 92 views

Badge +1

Hi Team,

I have subscribed started plan in Miro and integrated the Miro in my website, I can able to see the dev team boards but not able to see the normal boards, I am getting the below error.

 

I am suspecting this issue could because of I configured the client id of dev team, couldn’t able to create/see the client id for normal team board. My objective is integrate the normal team board, not the dev team board. What should I do?


9 replies

Userlevel 5

Hi there,

 

What part of live embed are you using? Have you followed these steps? 

https://developers.miro.com/docs/miro-live-embed-introduction

 

 

Badge +1

Hi @Addison,

This issue appears after the sign-in Miro and give the access the application. this issue not related to live embedded.

Thank you.

 

Userlevel 5

Can you provide a bit more context on what your app/website is doing? Including any methods, or endpoints from the REST API that you are using?

Badge +1

Hi Addison,

My application sign into the miro, then fetching the boards using get board rest api. Once boards imported, we displaying the board in our website using live embedded.

In this scenario, I am able to fetch the all the boards from the dev team, normal boards are not able to fetch. I am getting the failed request authorization error.

Please help me out.

Userlevel 5

When you sign in with Miro’s OAuth2 flow, you will need to pick a team you are signing into - are you able to sign into this team correctly? 

Badge +1

While picking a team only I am facing this issue. if I selected the dev team, I didn’t any issue. If I selected the normal team, I am getting the error.

Team pick up screen:

 

After picking up the team, I am getting this error.

 

Userlevel 5

I will send you a DM! 

Badge +1

Hi Addison,

I replied you in the chat.

Thank you.

Badge +1

Hi Addison,

Even I am getting same error in developer.miro.com using “Install app and get OAuth token” button.

See the screenshot here.

I hope this is the issue with the application.

Reply