How to whitelist localhost when calling Miro REST API?

  • 27 March 2021
  • 1 reply

Hello. I’m currently trying to integrate a Miro board into my website. While trying to get the oauth token from my local, I receive this error:

Access to fetch at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. If an opaque response serves your needs, set the request's mode to 'no-cors' to fetch the resource with CORS disabled.

Is there a way to whitelist my localhost and get the token?


Best answer by Daniela Gavidia 7 April 2021, 11:54

View original

1 reply

Userlevel 4

Hello @Michael Stramandinoli,

Are you still experiencing this issue? If so, have you added your url in the “Redirect URLs” section of the App Settings (in the Redirect URLs section)? I suspect that is the reason for the error. Please make sure that you put your redirect url exactly as it is registered in the App Settings. I have tried fetching the access token with a server running on localhost and was successful. 


Kind regards.