Bad Request: Deserialization Error when updating App URL

  • 18 January 2022
  • 10 replies

Userlevel 1

Hi there


I tried updating the App URL on my Web SDK app I resumed development on in my Dev Team under “Your Apps”.

Yet doing so gives me a “Bad Request. Deserialization Error” notification and not much more info.


Network tab res preview:


Also tried it on a newly created App, where setting the App URL failed for the same reason.

Haven’t changed any scopes. (Re-)installing the app doesn’t change anything.


Seemingly the same issue as this one from 7 months ago.

10 replies

Badge +1

I am having the same issue - I tried to create a new app, it produces those errors and as a result the permissions are not saved


Same here

I’m having the same issue when updating any of the application configuration… get the following response on any change (from the browser dev tools):

  "error" : {
    "message" : "Bad request. Deserialization error.",
    "reason" : "badRequest",
    "code" : 400

That issue still persists. We are trying to test a custom Miro app in a developer team.

Changes on the apps settings ( result in a 

Bad Request: Deserialization Error


Unable to update app scopes for a new application. Same error. 


Is anyone from miro reading this?

The bug seems to be fixed for us.


Userlevel 1

Indeed it has now also worked for me.


I’d still appreciate an answer from a Miro official though; Was something changed? Or will this bug potentially reoccur at random? And if the latter, then of course I would appreciate action on it.


Thanks anyway, also to those confirming the bug on their end.

Userlevel 5
Badge +1



Sorry for the late reply.

I have raised this to the technical team, they will investigate and I will come back to you when I have more information. 

Userlevel 5
Badge +1

I got the confirmation from the team that this was a regression that came with a deployment that happened a few days ago. It was fixed yesterday and should not face the issue anymore. 


Sorry for the convenience.