Uploading documents

  • 25 February 2020
  • 8 replies

I am benchmarking from someone elses board, and the documents they have in there show an option to open source file.  Whether I drag and drop, or use the upload option, my files seem to be stored on Miro instead of linked to the source.  Am I doing something wrong?


Best answer by Marina 28 February 2020, 13:34

View original

8 replies

Hey @Jarrod Davis,

Seems that your colleagues upload documents from cloud storages (Google Drive, OneDrive). In your case, you seem to upload the documents form the device.
Do Google Drive or OneDrive work for you?

I am actually using OneDrive.  The difference is that if I drop it in Miro using drag and drop, Miro acts like the document repository and doesn’t actually link to my file.  I have to click on Upload>One Drive>file.  Then it will upload it and keep the dependency link to be able to refresh.  

This is expected behaviour, I’m afraid. I hope that uploading via the toolbar is convenient enough and you will use it to have a link to the source :slight_smile:

Sorry to butt in, so I cannot upload a file directly, only as an URL to some external service?

@Alan, it depends on the file you are trying to upload. There are a lot of file formats Miro supports (more in the article) and also you can check the article on uploading files to the board.

Mmm, the article says it can accept PDF but when I try it just says ‘Something went wrong’. It’s a single page invoice, less than 200kb.

It opened the file upload dialogue OK, I could select the file, it just failed to upload.

Not sure what to make of that. 


I’m afraid this is a support question. Will you please reach out to the Support team at

I tried the ‘send a bug report’ which mostly worked, I think :)