SHARE icon is missing

  • 16 April 2021
  • 6 replies
  • 28 views

Badge +2

For many boards, I have noticed that SHARE icon is missing in the top right corner of the screen.

For same boards, my company admin does see SHARE icon as visible.

What could be the issue here?

Please advise.

Thanks, 


6 replies

Userlevel 7
Badge +16

@Anant Agrawal - That usually indicates that you are a guest on that board and not a team-member of which the board is located in.

You can check your role by hovering over your avatar:

 

Badge +2

 

Here is the screen-shot….of my status. It shows GUEST EDITOR. How do I change it?

In another board under same project, my status shows as EDITOR

 

Userlevel 7
Badge +14

@Anant Agrawal -

In the latter case, the board has been shared with you or with one of the teams you belong to in Miro with full edit access whereas the first one was shared using the anonymous guest editor access. You’d have to ask whoever shared the former board to share it directly with you or with your team.

Kiron

Badge +2

Thanks, would you know the steps to share board directly with me or with my team?

Userlevel 7
Badge +14

@Anant Agrawal -

The board owner can access the Share settings from either the dashboard (… menu) or the board itself and add you or your team in the highlighted areas of the Share dialog below with full edit access. Be aware that if you aren’t already a paid member of their Miro account, by doing you will be added as a paid member.

To see who the Board Owner is, click on the name of the Board (top left side of the screen) while it is open and you’ll get that info in the board info dialog.

Kiron

Userlevel 7
Badge +16

@Anant Agrawal - To add to Kiron’s comment about clicking on the board title to determine the board owner, and as a note to all readers, if you try to click on the board title but it is not clickable/a link, this is due to the Board Content Setting’s being configured to NOT allow non-team members to be able to copy/duplicate the board - it is just unfortunate that this also blocks the Board details screen from opening up.

So if I set a board’s Board Content Settings as follows:

… then this happens to both anonymous and registered guest editors:

Cannot open the Board details modal

 

Reply