[RESOLVED] Windows App is crashing immediately

Hi there,

Windows 11 app is crashing after opening any board. This is an issue after the update, I guess two days ago.


Anybody experiencing the same issue?

Alyona 2 years ago

Hey everyone,

Our team just released a new version of the Desktop app (0.7.12.) that potentially can resolve the issue you all experience. Currently, it's only available on the website

Please delete the previous version from your devices entirely and then install the new one. Let us know if this helped, or the crushing happens with the latest version too. Thanks!

View original

35 replies

Yes, exactly the same. After the latest update the app stopped working and the new app won’t install. I use Miro regularly on Win10 64-bit. 

Userlevel 6
Badge +1

Hey @ozgurkalan and @G Salani 👋

Alyona from the Miro Support team is here. 

Could you please re-confirm whether you're using version 0.7.9. and also if it was downloaded from the Microsoft Store or our website? This information will be helpful so our developers can identify the root cause of the issue you're experiencing. 

Hello. Yes it’s the 0.7.9. It was an automatic update, plus I reinstalled it from your website. I hope you can resolve this soon. Thanks


Userlevel 6
Badge +1

Thanks for the additional information!

Our team is looking into this right now, so hopefully, the bug gets fixed soon 🛠 I'll let you know once we have any updates. Please bear with us! 

Thank you

Userlevel 6
Badge +1

Hey @ozgurkalan and @G Salani,

I'm afraid we still could not reproduce the behavior you reported, which is a necessary step to fix it then. In addition to that, we had only one similar report, and that user came back a few days later to let us know that the issue disappeared after they reinstalled the app one more time.

That's why I wanted to ask you whether you're still experiencing the crushing?

Hello, thank you for looking into this. I’m afraid I tried to reinstall Miro for Win10 64-bit several times but with no success. It loads for one second and then disappears. I use Win10 on a Lenovo ThinkPad X1. My system is up to date and I’ve been using Miro every day for over a year with no problems before the last update. I hope you can solve this issue soon.

Hello @Alyona , I am also experiencing this issue exactly the same as @G Salani . The app opens for a second then disappears. Mine was 0.7.9 Win10 64-bit and installed from the miro website. I have tried to uninstall and reinstall with no luck (now at 0.7.10). I would be more than happy to provide any extra information to assist?

Very quick update. The miro app works if I right click and run as administrator, unsure why I all of a sudden need to do this to make it work, but work it does.

Just to add I have tried that and it doesn’t work on my laptop.

Userlevel 6
Badge +1

Thanks for the input and your patience, everyone!

I've discussed your case with the team further, and due to the peculiarities of the desktop app installation on Windows devices, we'd like to ask you to try a few more things.

First of all, please try resetting the app's data as described here. We ask you to do that because the app doesn't reset automatically upon re-install.

If this won't help, please completely remove the app before re-installing it. For that, you'll need to:

  1. Remove the app from the control panel
  2. Remove C:\Users\{username}\AppData\Roaming\RealtimeBoard folder
  3. Remove C:\Users\{username}\AppData\Local\RealtimeBoard folder
  4. Remove C:\Users\{username}\AppData\Local\SquirrelTemp folder
  5. Install the app again

Please, let me know how it goes!

I had the same problem.  Miro crashed on load.  I removed these folders, did a fresh install and things are working fine now.  Thank you.

Windows 11
Curent version downloaded from the Windows App Store.

Hello. Unfortunately this didn’t work for me (Win10 64bit). I removed the folders and tried to reinstall from both the MS app store and your website (I tried a few times, just in case). The app loads fine, I can see my boards but as soon as I click on one the app crashes and disappears. Then it won’t load again. Thanks.

It only worked the first time for me.  Now I have to run it as an administrator to get the app to work.


Userlevel 6
Badge +1

Hey @Darren Terrell and @G Salani,

Thanks for your input!  

Could you let me know if you reset the app's data before deleting the listed folders and reinstalling the app anew? 

Hello. I can’t reset on the app as it doesn’t load at all. And the option “Advanced options > Reset.” is not available on Win10, just “uninstall”. Thanks.


Yes, I tried resetting the app’s data, but that did not fix the issue.  The only way this will work is if I run it as an administrator.  I think I understand why.  Here are two snippets from two events found in the Event Viewer that may shed some light for your engineers - looks like a permissions issue. I can reproduce this whenever I want by not running as the administrator.  If your engineers would like to jump on a Zoom call, I can demonstrate what’s happening and we can look at the events and app data on my machine.  

Event #1
Log Name:      Application
Source:        Application Hang
Date:          4/27/2022 4:32:43 PM
Event ID:      1002
Task Category: (101)
Level:         Error
Keywords:      Classic
User:          N/A
The program Miro.exe version stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Event #2

Log Name:      System
Source:        Microsoft-Windows-DistributedCOM
Date:          4/27/2022 4:40:31 PM
Event ID:      10016
Task Category: None
Level:         Warning
Keywords:      Classic

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID  {2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
 and APPID {[removed]}  to the user [removed] SID ([removed]) from address LocalHost (Using LRPC) running in the application container RealtimeboardInc.RealtimeBoard_2.1.6.0_x64__h77ag88wp8xmr SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

I do want to point out that running on elevated privileges is not a good substitute nor an available option for everyone. 

Hello @Alyona following your instructions only helped the first time for me also. its run as administrator or nothing when using the app.

Userlevel 1

Hi @Alyona,

I am experiencing exactly the same issue of immediate crashing on two computers.

Windows 10 64bit, and Windows 11.    Miro version 0.7.11 desktop app

Back on March 11 everything was working just fine. Now Miro crashes very quickly after load, unless running in Administrator mode.

I’ve tried uninstalling and deleting app data before reinstall, but that only helps for about a minute.

I have also found I can start the app in normal mode when displayed on my 1920x1080 monitor, but then I attempt to drag the app window to my 4K monitor it crashes the moment it tries to change the scale.

How can I roll back to the version from March 11 (not sure which that was)? I have a big presentation tomorrow and would love to have a working Miro not running in Administrator mode (because my Streamdeck hotkeys don’t work with it in Admin mode.)

Userlevel 6
Badge +1

Hey @Steve Morris,

Thanks for sharing your case in such a detailed way with me!

I'm afraid it's not technically possible to revert the app's version, so for your presentation we would suggest using the web version instead of the Desktop app.

@ozgurkalan, @G Salani, @Rich Turner, @Darren Terrell could you let me know if you're also using external monitors with high resolution? 

@Alyona - not using an external monitor.

Hi @Alyona, yes, I attach my laptop sometimes on a monitor. By the way, I have tried the above mentioned workarounds and still end up with self-closing app. FYI. 

@Alyona yes using external monitor not 4k