Answered

Miro board no longer letting me edit

  • 18 August 2020
  • 1 reply
  • 2729 views

I created a board yesterday and shared it with my team. We worked on it today.  When I returned to it this afternoon I could no longer do anything with the elements on my board. I would really appreciate some advice as to what to do.

icon

Best answer by Simon.Harris 18 August 2020, 11:45

View original

1 reply

Userlevel 4

@Charlotte Forwood - a few thoughts occur.

If your accessing in the same browser or app session as yesterday then have you tried ending your miro session and starting a new one? - I’ve had strange behaviours that got cleared using a new browser session

Have you tried the desktop app and a web browser - again I’ve had oddities in one that didn’t happen in the other and seemed to clear the behaviour

Did one of your team members lock stuff and your now trying to select or otherwise “do” stuff without unlocking? - can you select the elements on the board? - Can you add elements? can you pan around on the board - how ‘broken’ is your access?

You might also like to try exporting the board’s content using the icon next to the board’s name top left - download board back-up enables you to reload it

Reply