Embedded Miro board doesn't work on iPhone and iPad

  • 2 December 2020
  • 14 replies
  • 1072 views

I am trying to embed a miro board on my website. It works great on desktop and on iOS on an iPad, but it freezes on my iPhone, both in chrome and safari. Here’s a link to the test page on my site:

https://rangr.com/test_miro.html

Thanks for any help!
 

 

Jasmit Rangr 2 years ago

Hi @Uma, 

Miro started a support ticket for this, but I have not heard back since the ticket was started. I’ll post here if I get any further responses.

 

View original

14 replies

Hi @Jasmit Rangr,

Sorry to hear this. I’ve converted your post into a support ticket. The team will investigate the case and get back to you via email.

We used Miro's iframe whiteboard embed integration with angular 6. While it is working fine on the desktop, it doesn't work on the iPhone and iPad.

in iPhone and Ipad, the Whiteboard container loads the button "see the board" is seen. However while clicking on it, the board is not loading. Any suggestions here would be of immense help.

Userlevel 7
Badge +8

@Manjula Manoharan ,

have you tried an other Browser f.e. Firefox or Chrome?

If you have tried and this doesn’t work please contact the support-team:

https://help.miro.com/hc/en-us/requests/new?referer=community

 

Michael

Thank you for the reply @mlanders , I will try in those browsers.

Userlevel 7
Badge +8

@Manjula Manoharan 

It would be great if you can leave here a comment what have worked best for you so other iPhone / iPad Users seeing what helps best.

Michael

@mlanders , I tried checking in those browsers and the same issue exist there too.. I raised a ticket, if anyone knows how to fix this, It would be of great help.

 

 

 

Hi @Jasmit Rangr 

Were you able to overcome this issue? I’m facing the same issue and need help on this

 

Hi @Uma, 

Miro started a support ticket for this, but I have not heard back since the ticket was started. I’ll post here if I get any further responses.

 

Thanks a lot @Jasmit Rangr ! Will wait to hear back… In case I come across anything useful, will share it too

 

Userlevel 1

Hello! Has this been resolved? I am running into this same issue when embedding Miro into my application. Any help would be appreciated. @mlanders @Marina 

Userlevel 1

Hi @Jasmit Rangr! It seems like you’ve managed to get this miro embed working. I even tested it on Safari for iPad and it works flawlessly. I am trying to embed a miro board via iframe as well but it seems that it just won’t load on Safari for iPad. On desktop it’s working flawlessly, however it is crucial that it also works on mobile. So far, it works fine on Chrome for iOS. Is there anything that you may have done differently when creating the iframe that would make it work on Safari for iOS? Any help would be appreciated!

Hi, I forgot I had this test page out there! I kind of gave up on this idea. FWIW I put the iframe in a div. I’m no expert in HTML so this may be messy, but here’s the code I used:

<div style="height:100%; width: 100%""; overflow:hidden; float:right; border: 0px solid #b2b2b2;">   
  <iframe width="100%" height="100%" src="https://miro.com/app/live-embed/o9J_kk3amiE=/?moveToViewport=-3002,-781,11511,9623" frameBorder="0" scrolling="no" ></iframe>
  <br/>
  </div>
 

I left the “border” in the div, you can toggle the width from 0px to 1px to see what the div is doing.

Hope that helps.

Userlevel 1

Interesting… It seems that the issue is that your board is set to “View Access” while mine is set to “Edit Access” for anyone who has the link. This is a big issue for my use-case :(

Hello all. 🙂 Is the problem solved in the meantime?

I also have the problem so that a Youtube video that is embedded is visible on the Iphone, but it does not play when I press on the video.

On the desktop it works fine.

Any help would be greatly appreciated. :-)


Harry Grubert

Reply