Boards are very laggy and slow on desktop app and web app

  • 22 February 2023
  • 51 replies
  • 3375 views

Userlevel 2
Badge

Hi, I noticed during the last one week all my boards are very laggy and slow. It takes up to 5-6 seconds for the board to respond to an interaction. This is incredibly annoying and looking at the history of this issue - it appears it is quite a common problem. Please would you look into this and resolving it once and for all?


51 replies

Userlevel 4
Badge +1

Hey @Silviya Lardner ,

Sorry to hear the performance of your boards isn’t up to par. 5-6 seconds for any interaction sounds awful. Is this a developer platform issue? Or just a Miro.com issue?

Could you test if this problem persist when:

  1. You restart your machine
  2. Open just a web browser and start a new miro board (https://miro.new) 
  3. Add 1 item to that board

This way, we can determine more precisely where the problem lies.

Also: what browser/OS are you using? https://www.whatsmybrowser.org/

Kind regards,

Mettin Parzinski

Userlevel 4
Badge +1

As a long time user of RealTimeBoard and Miro, I consider myself a Power User, I also have found the performance of late to be suffering. Specifically the Desktop App is always disconnecting and is suffers from speed lag.

Userlevel 4
Badge +1

Hey @Brandon Lee!

Thanks for the input. We have performance on our radar and it is something we have multiple teams working on at the moment. Miro is a huge, complicated app so its not a flick of a switch unfortunately!

Sorry that I can’t be of more help at the moment. Just know we know and are working on it!

Cheers,
Mettin

Badge

I only can confirm the decrease of performance in miro over the last months. I have to reload several time after a while to get back a little bit better performance.

I depends on how much images are in a board as well as on the internet connection.

I hope this can be improved soon because it really has impact on my work performance.

Thanks 

Userlevel 4
Badge +1

Hey @YOO ,

While it makes sense that ANY internet-dependant application becomes slower when your internet connection is slower, it doesnt make it any less annoying!

Miro is quite smart with (not) loading data that’s outside of the viewport. So you could use that to your advantage by having some more space in between your images, if your use-case allows for it. Less items in view = less items downloaded = more speed =)

Cheers,

Mettin

Badge

I am getting pretty disappointed now with the slow and laggy response with my Miro boards. This is particularly frustrating when leading a meeting - everyone has to wait while I refresh the board just so we can get a sticky note loaded.

What has happened Miro? This issue has only just started happening recently and I have been using Miro since the start. I am serious considering transferring to a competitor platform if this does not get resolved soon. Specifically our issue is: frequently when selecting any item from the LHS screen toolbar (stickies, text, shapes etc) they don't appear on the board. We have to refresh the browser for it to work.

Please get this resolved. Thanks.

I have to chime in on this.  I have been a ginormous proponent of Miro, but its getting laggier and laggier to use on smaller and smaller boards.  I’m close to going back to other apps because the lag in creating, editing and moving objects is just too much.

Hello @Mettin 

Perhaps this will help. It seems that the slowdown can be associated either with the entire account, or with the parameters used by the shapes. I have a board with 6k elements. Transferring some of these elements causes another 1k board to lag.

My slowdown is associated exclusively with shapes. And only with the transition to their editing mode and exit from it.

Reproduced on mac m1 pro and on windows, web version and desktop version. But it does not slow down on android! There, the same slow board runs faster than the speed of light. Sticky notes work very fast everywhere.

Userlevel 4
Badge +1

Thanks @A G for the input! If im reading it correctly, it seems like a super weird behaviour that should be fixed asap.

Just to be sure I got it 100%:

  • You have 2 boards open
    • 1 with ~6k elements 
    • 1 with ~1k elements
  • If you move items on the 6k board > the 1k board also starts lagging?

Cheers,
Mettin

Yes, it slowed down when I duplicated them. I duplicated some of the elements from the 6k board onto the 1k board just for experimentation, and the shapes on the 1k board started to lag too. On the 1k board, there were only 300 shapes in total. However, they began to slow down.

And only the shapes are slowed down. I started using cards and sticky notes, everything is ok with them

Userlevel 4
Badge +1

Seems normal that if you copy/paste 5k elements its a bit laggy initially.

But that should be placed in memory and become more performant later on. Ill pass along this scenario to the performance team. Thanks @A G !

 

Userlevel 4
Badge +1

@A G Are you able to share (duplicates?) of the boards by any chance?

@A G Are you able to share (duplicates?) of the boards by any chance?

i made a board with exapmles of shapes. There are ~700 shapes on this board and it is slow even now. It is called “Example for Mettin” in my account, but it seems that the sharing gives access to all the boards of the team at once :(

Hi!

Since a couple of days my Miro boards are also very slow. Moving an object or typing is taking several seconds to see the movement. This is with all the boards; even I make a clean new board and just draw one shape. This makes is not possible to work with Miro at the moment unfortunately.

I tried closing all other programs; different devices, but the problem remains the same.

Could you help me with this issue?

Thnx!

Hello @Mettin,

Same problem as E.D. since a few days. No way to work with shapes, other object types behave as usual. 

Tried everything I could think of: Closed boards to work only with one, created new board with only one shape, installed Miro app new (Mac Intel), …

Thanks,

Petra

 

 

Userlevel 4
Badge +1

Thanks for chiming in @Petra Werhahn and @E.D.. Very sorry to hear about this experience.

I have passed along your comments to the performance team. In the mean time, did you have a look at the performance tips over at https://help.miro.com/hc/en-us/articles/360013588560-Board-performance-and-loading-issues?

The most important thing is this step:

If the performance issues persist with a new empty board, in incognito mode please get back to me!

(Small FYI: im off on vacation for 3 weeks, starting next week so I will make sure to ask a teammate to watch this space)

Cheers,
Mettin

Hello @Mettin,

thanks for the performance tip, will check it.

But today it seems to work in the app as usual. For now no problems :)

Have a nice vacation,

Petra

Userlevel 1

I’m going to be straight with you here. This is not good enough for a payed product, and I will begin my research and advice my team on better solutions elsewhere.

It must not take 1 second to select or move an object, or update a text field. And this issue must absolutely not stretch on for days.
Yes, I’ve cleared my cache in chrome, and I’ve tried using Firefox, and on several different high speed connections in different places.


I can’t stress this enough: Stop putting this on your users. Fix your payed product if you value having your users around.

EDIT: And just to stop the default before it gets going. Even though I’m not your QA, I tested the desktop app, showing the exact same issues. On a, tested just now, 334 Mbps download and 69p Mbps upload speed. I have a direct line of sight to my router 4 meters away. No, it’s my connection.

Hi @Mettin 
I’m having different problems with the Miro app, for ejample:

  • very slow reaction copy and paste a text box (3 second on average) having just one board open with less than 5 elements.
  • Very slow reacion when click to write text or select any element to edit
  • On long texts, there are withe moving characters all over the place that make very difficult to read it

I use Miro avery day. I started to notice these issues when Miro changed the layout and introduce new features, and it became worse with the new AI features.
Is Miro working in fixing the current problems? If not, I’m afraid I would need to find another app.

Thanks

Userlevel 3

Agreed. Especially single or double clicking on text boxes, and then editing. Lately there’s noticeable lag on all of those fronts

Userlevel 4
Badge +1

Thanks @Martin Malmer , you are completely right. 

We have teams dedicated to improving performance but I hope you can appreciate that the Miro application is huge and complex and although we wish we could to make it more performant for every type of use case, this is a much more in-depth process. 

I understand your frustration and we are actively working on improving this issue for you and all our users.

Cheers,
Mettin

Badge

I can provide some general advice and possible solutions for dealing with such problems:

1. Check Your Internet Connection: Slow response times can sometimes be attributed to a poor internet connection. Ensure that you have a stable and reliable internet connection to minimize potential issues.

2. Clear Cache and Cookies: Cached data and cookies in your browser may sometimes cause performance issues. Clear your browser’s cache and cookies and try accessing Miro again.

3.Update Your Browser: Make sure you’re using the latest version of your preferred browser. Outdated browsers may not be optimized for the latest web applications.

4.Try Different Browsers: If the problem persists, try accessing Miro through different browsers to see if the issue is browser-specific.

5. Disable Browser Extensions: Some browser extensions may interfere with the functionality of web applications. Try disabling any extensions that might be affecting Miro’s performance.

Userlevel 1

@Mettin “we wish we could to make it more performant for every type of use case”

Please stop this. It has been working fine up until at least a couple of weeks ago, and then I come back after vacation to an unusable work flow. There is no “my type of case”, unless Chrome users, Firefox users, desktop app users and fast internet speed is outside of your scope.
Obvioulsy you rolled out an update that wasn’t thoroughly tested. Is it the AI thing?

Anyway, no need for me to lose more time on this. I’m testing Figma and XD as we speak. Things will be panning out fine for me whether I find a more stable product or you fix the issues on your end before that.

Userlevel 3

Hey @Martin Malmer, your tone is coming across needlessly harsh for this community.

Especially putting quotes from @Mettin’s response and then adding disparaging remarks. it simply isn’t the way to go about resolving issues or make people want to listen to what you have to say.

Product teams are real human beings doing their damndest to bring their customers what they need with the resources they have available. Things break, and they will get fixed according to priority and resources. You will find things are no different with Figma and XD 🤷🏻‍♀️

Editing text etc. still works fine, it’s just more laggy than usual. Not perfect, but also not a burning house. So time to turn the fire alarms off.

Userlevel 1

@Lucie A True. And indeed we are all people. And I would have been perfectly happy with leaving it without my last remark, while I figure out what I want for me going forward. But waving me off as just a another “type of user”, and that they wish they could make it work for everybody, will lead me to inform my position and next steps. I’m sorry that my stern tone offended, but I take it pretty seriously.

I’m not going to start a debate on what is fast enough for you, or debate other products. These forums are not for that. It was merely a statement of how seriously I take the speed of my workflow, and the current state has lead me to take such actions. Take that as you will. Either way, I didn’t find that I have to wait around for a server response for each mouse click elsewhere.

I also don’t like this position of keyboard warrior, so I will end this here for my part. Information has been shared. I won’t be hanging around here further.

Reply