Question

Opacity sometimes not set

  • 26 March 2024
  • 9 replies
  • 55 views

Badge +1

Hi all,

I am new to this community, so please excuse any mistakes.

I have been using the Rest API for 2 months now to programmatically create board contents. Everything worked as documented and I did not have more than the usual problems.

Today, I am observing a very strange behavior: When creating a shape, the fillOpacity values are sometimes ignored and set to 0.0. However, there is no pattern, i.e. if I create the board contents several times, the elements having the wrong fillOpacity are not identical, but vary a lot.

I did not change anything in my code regarding fillOpacity, so I suspect that something has changed on the API side.

Any help is highly appreciated!

Thanks, and best regards,

Rene

 


9 replies

Userlevel 3
Badge

Hi @ReneS, thank you for bringing this to our attention and I’m sorry you’re experiencing this issue. Our team has confirmed this issue from this endpoint and is investigating it. 

I will let you know once we find the solution. 

Badge +1

Hi @Horea Porutiu,

Thanks for the update. I have implemented a workaround, so my content looks fine again, albeit at the cost of updating the fillOpacity of the shapes until they fit my needs.

To me, it looks like there is a load balancer serving that endpoint and one of the servers behind that load balancer always sets the fillOpacity to zero. At least that would explain that the problem only occurs on a fraction of the shapes created and always different ones.

Hi,
I am experimenting the same issue.

Initially, yesterday, it happened randomly for some requests. Now, all requests for shape creation or update seem to be consistently impacted, which renders the REST API completely unusable.

@ReneS I had tried a similar workaround of updating the shapes after they were created, but I suspect it was only (partially) working due to the fact that only a fraction of the requests were impacted (so some of the update requests could be successful). Now that all requests reset fillOpacity, the workaround is not usable anymore. 

Notes:

  • borderOpacity seems to be also impacted
  • Avoiding to provide a fillOpacity value when the shape is created does not seem to help
  • Retrieving a shape’s style always returns a fillOpacity value of 0, even a different value is set through the Miro GUI

@Horea Porutiu Is there an estimated time for fix being deployed? Are we talking hours or days?
Sorry to be a bit pushy, but I need to generate a rather big board for an event with tens of people attending… so I need to know whether Miro will still be an option.

 

Userlevel 3
Badge

Hi @Lionel Capiez I’m sorry you are experiencing this issue. 

We are investigating this now and will deploy a fix as soon as we can. I will let you know once we deploy a fix. The timeline is uncertain right now, but will confirm with you as soon as I hear more from the eng team. 

Badge +1

Actually, I don’t observe the problem anymore...

Userlevel 3
Badge

We just rolled out a fix. @Lionel Capiez could you please confirm it solved your issue as well?

Thanks for confirming @ReneS .

Hi @Horea Porutiu,

It is resolved for me also. Thanks a lot!

Lionel

Badge +1

Yes, thanks a lot for your swift reaction and fix!

Userlevel 3
Badge

Thanks for confirming @Lionel Capiez! Thank you @ReneS for your quick response as well.  

Reply