Custom Web Plugin not working

  • 9 July 2021
  • 3 replies

Hi, my team and I have created a custom web plugin which was working properly. When a new team member was added, he could see the web plugin icon but the custom feature didn’t work at all. This is what we get as an error: “Uncaught (in promise) Error while command execution: Method 'board.widgets.get' requires scope 'boards:read'”. 


We have already allowed the “board:read” permission for our app. So I tried to reinstall the app but it seems we need to authorize the app. So I tried to authorize the plugin but I and my team get this message.

We have subscribed for a team account and I am not sure how can we get this plugin to work again. I also tried to create a new app but this same message appears every time. 


Am I missing out on anything? Please help me out here!




3 replies

Userlevel 5
Badge +1

Hi @Taylor Mason,


Which scopes did you enable for your app? I see you have enabled “board:read”, any other permissions?

Hi @Anthony Roux ,


Thank you for your reply. I have enabled all the permissions for the app.


Userlevel 5
Badge +1

Your issue comes from “auditlogs:read”. Audit logs is available only in Enterprise plan. 


Uncheck this scope and try again.


Have a great weekend :)