Answered

Zoom and panning oversensitive with trackpad

  • 20 July 2020
  • 7 replies
  • 1458 views

The title says it all, panning is way too sensitive and makes it really hard to get around my boards. Zoom is by far the worst, only allowing me to toggle between the following zoom levels :14%, 73%, 382%, and 400%.

Any help to fix this would be greatly appreciated. I have of course tried every navigation mode, without luck. 

icon

Best answer by Robert Johnson 20 July 2020, 23:41

View original

7 replies

Userlevel 7
Badge +12

I believe the zoom intervals are a representation of your computer's operating system settings. I have no experience with Apple/MacOS, but I believe that in Windows, this is somewhere in system settings > Touch pad > Pinch to zoom(?) or in your 'Line numbers to scroll' using the wheel on a mouse. I can remember the exact settings as I'm not near a computer at the moment, but essentially it should be somewhere in your OS settings and not Miro. My number of lines to scroll was at 3 or 5 in Windows 10 and once I lowered it to 1, when I scrolled the wheel in the mouse while in Miro, it zommed in/out at lower increments.

@Rob Johnson I can’t find the setting your talking about (I’m using windows).

Also, I’d be surprised that this would fix it as I don’t have any issues in other programs, but just in case would you be able to try and find the exact location of the setting you’re talking about ?

Userlevel 7
Badge +12

@Mindoo I had a look on my laptop and it appears that the behaviour I described has changed - I was directed by support to change the Chose how many lines to scroll each time setting in Settings > Mouse back when Miro was RealtimeBoard.

I was just playing around with the various Miro board Navigation modes found in a board > settings icon (top-right) > Navigation mode, as well as adjusting both my Windows Mouse and Touchpad settings and cannot replication the behaviour you are describing. In all scenarios, I can smoothly zoom and pan using both the touchpad and my mouse.

My settings:

  • Dell Inspiron 7375 with Windows 10 2004 (Home Edition)
  • Latest Chrome browser and Miro 64-bit app
  • Logitech m325 wireless mouse
  • I have my board set to Mouse Navigation mode (right-click on any blank spot in a board or use the settings icon at the top-right and select Navigation mode)
  • Mouse and Touchpad settings found in Windows by pressing Windows key + i to load settings, then search for “Mouse settings” or “Touchpad settings”

I couldn’t find anything that sounds like your issue when searching the help files at https://help.miro.com/

I would suggest reaching out to Miro support for further assistance. From either your Miro Dashboard or from within a board, click the help ("?") icon at the top right and then “Support". This link should work too.

Good luck!

@Rob Johnson Ok sounds good, I’ll reach out to support.

Thanks for your help anyways !

@Robert Johnson 

Thank you for your answer, unfortunately, I have the same problem, and all my colleagues as well. We use the “Mouse” navigation option instead, even if they would have preferred “Touchpad” with a mouse connected, had it worked correctly.  

Changing the scroll settings in Windows works, but then the scroll step is too small on other apps like Outlook. It feels like Miro is the exception here - Ctrl+scroll zooms in way too much.

I’m using Windows 10 1809, bluetooth mouse. The problem occurs in both desktop app and website on chrome. 

I ran into a very related issue on a macbook. Zooming in with CMD+Scroll Wheel would jump unhelpfully between 400% and 36% (I think that’d be CTRL+Scroll Wheel for Windows users). However, if the app detects that I’m using “Mouse Navigation” automatically… then just using scroll wheel (without any key modifier) will scroll much more smoothly.

Unfortunately, I had to override the “Auto Switch” Navigation device option to always be “Mouse” to consistently treat scroll wheel as zoom. This seems to be the only way to get a sensible zoom step on my macbook when a mouse is plugged in. I think Miro detects that I have a track pad present, and “Auto switches” to “trackpad” for some reason. I’m not sure if this is a bug, or something to do with my hardware and dock setup.

My preference would be to always allow CMD+Scroll Wheel to function as this more sensible zoom step regardless of the Navigation Device option, as that keyboard shortcut is what I’m used to from other 2D drawing platforms (CAD mostly), and it’s current behavior isn’t that valuable. Unfortunately, that likely won’t be to everyone’s taste so my ask is likely a full-blown navigation preference section with customizable keybinds………………. :(

TL:DR The workaround is to make sure your Navigation preferences are set to “Mouse”, and DON’T press CTRL or CMD when scrolling.

I tried the above suggestions of switching Navigation settings on my MacBook from `Auto-switch` to just `Mouse` but the zoom scrolling is still too sensitive for me.

I wish there was a setting to adjust the mouse sensitivity. I could see the need for this to be different depending on what kind of board you’re working on.

Reply