Unable to duplicate my own board (I am owner/creator)

Userlevel 2

Hi friends! I have a huge master board that I like to backup with a duplicate copy often. Today, I’m unable to do so, no matter how long I “wait” (which believe me, is a LONG time).

Meanwhile, I have been able to successfully duplicate my other boards today.  Has this happened to anyone else? 

16 replies

Userlevel 7
Badge +12

@Anne Scarlett - What happens when you try to duplicate it?

  • Does it just say “Duplicating...” at the top, forever?
  • Do you get an error?

Are you doing this from within the board (clicking board name → Duplicate) or from your dashboard (right-click board → Duplicate)?

Are you using a browser or the Miro desktop app?

How many objects are on your board - you can right-click on blank spot the board, select Unlock all, then Ctrl/Cmd-A to select all and you will see an object count in the context menu that appears.

NOTE: Then Ctrl/Cmd-Z to undo the “Unlock all”!


Userlevel 2

Yes, it says “duplicating” forever (literally!)

This is happening from the dashboard AND from within the board.

Using the Chrome browser AND Safari browser. Should I try from desktop app?

Unfortunately, I did “unlock all” (it said 803 objects at the bottom, but I have WAY more than that) and then when I did “undo” to relock, it only did a ‘regular lock’ rather than a ‘board owner only unlock’. Yikes!!! I had everything “super locked”. What do I do?

Userlevel 7
Badge +12

You can click the locked objects and apply the Protected lock again - details in this article:


The reason I suggested unlocking all objects was so that you could then select ALL objects on the board using the Ctrl/Cmd-A to shortcut. This would then show you a total count of all objects on the board.

Userlevel 7
Badge +12

And, yes, give the desktop app a try.

Another question: If you have a paid account, have you tried downloading the board as a .RTB file and then importing the backup to see if you can Duplicate the restored board?

Userlevel 2

Oh yes, I forgot to say, I *did* try selecting all, but then I couldn’t see the total count on the board. There was no context menu that popped up.  Unless I’m crazy! Here’s a screen shot. 

In the meantime, I’m having trouble ‘relocking’ as ‘protected lock’ in one click. I sure hope I’m able to do that, because I have hundreds of items that should be ‘protected locked’.  I’ve looked at the article you sent, but I’m unclear on how to switch them all back to protected at once. (I’m sure I’m overlooking something right in front of my face!)


Userlevel 2

I’m a professor, so have an ‘education’ account, which I think acts like a ‘paid’ account. 

However, I’m sick to my stomach because I really want the original master to work----as I wanted to keep the same link for all my users. If I do any of the solutions that we’ve mentioned, then the link has to change. Even so, I like to duplicate to keep backups - just in case.

At this point, I’m at a loss. 1. I’ve tried to duplicate from the app - it didn’t work. 2. I’ve tried duplicating a backup of the board that I created earlier today before lots of changes - and that did work. But it doesn’t help me because I wanted to keep the master board link the same for the users and I also made tons of changes that I’d now have to re-do.  

All in all, not a good situation so far. 


ps. is there any chance that when I uploaded from Google drive (to replace some documents so that users could view and download without copying the rest of my board content) that it created a glitch? I might be able to restore from a prior version? BUT would that keep the same link for my users?

Userlevel 7
Badge +7

@Anne Scarlett I doubt the Google Drive link created a glitch, although it's not impossible. I'm a bit confused about your situation. I thought you only wanted to create a backup, but it sounds like you've created a duplicate version that you've been updating?

Userlevel 7
Badge +12

@Anne Scarlett - Hmm. Once of the selected objects is causing the Protected Lock to not show up. Let’s not worry about that for now.

To get back to where things were before everything was unlocked, you should be able to restore a previous version of the board. Hopefully this will resolve your Protected Lock and duplication issue. If it doesn’t solve the locking issue, and you don’t anywhere with the next option, please post back and we’ll try to help you with that.

If you really want to maintain your current master board link, another approach would be to download the board backup and restore it (already done), and then you’re going to “re-create” all of the content on your master board by deleting it all and adding it back - hopefully this will fix any glitches in the backend and allow you to duplicate it again. There are at least two ways you can do this:

  1. Create a Custom Template from your master board, then delete everything from your master board, close it and re-open the board, and add the Custom Template back. If this doesn’t work, you could:
  2. Delete everything from your master board, close it, re-open it, and then open your restored backup and copy-paste everything from that board back onto your master board.

Unfortunately with both of these options you will have to re-lock and protected-lock everything.

In the future, if you want to have very large boards with many thousands of objects, you could explore the option of splitting the content into different boards and embedding boards within boards. At least then you could always have one master board link, but your embedded boards could change as often as you’d like with no impacts to your participants.  

Userlevel 2

@Henrik Ståhl Here’s my reasoning for creating all these duplicates: Currently, the boards create different ‘versions’ that you can ‘restore’ if needed. Those versions serve as a backup to save work. However, it’s a hassle to know what exactly is in each version, without actually restoring the version. (I wish there was a way to ‘preview the version’ before ‘restoring’! 

As such, my workaround is to create duplicates often, where I can then add notes/rename so that I have complete clarity on what that current iteration entails. 

Mainly, I’m a weirdo that doesn’t want to lose work--therefore, I save probably too often by creating duplicates (with the hope that I never have to use those as the ‘real thing’, since I wanted my master board to have a pure, unchanging link). 

Not sure if the above makes sense, but that’s my thinking :) 

In the meantime, I’m now in a quandary, because: 1. my master board has thousands of items that are now on ‘unprotected lock’ as opposed to ‘protected lock’. 2. as such, I will likely need to restore back to a point where all the locked items were protected, which will mean my link to my big master board will change. I wanted to avoid changing the link---it would be far cleaner for my participants to have the same link for all sessions. 


@Robert Johnson I hear your idea about having a master board, where prior parts could be ‘embedded’. In fact, I do that for the ‘prepwork’ -- embedding those boards into the master board. However, I find the experience when clicking on an embedded item is clunky...in fact, when folks are trying to run zoom and miro and then they have to click on an embedded item, it doesn’t go well. As a result, I typically have the embedded item actually open on a separate tab during the facilitation, so I can jump to it quickly….provided I’m just referencing it on a shared screen on Zoom rather than making people revisit that prepwork board themselves. 

That’s a poor quality explanation, but I hope it makes a tiny bit of sense.  

Later today, I’ve got to figure out my plan. I think it will look like this:

  1. Give up on having the same link to my Master Board---it seems that board must somehow be tainted, since it can no longer be duplicated. Further, that board is now on ‘locked’ but not ‘unprotected lock’ for thousands of items. I’ll go insane if I have to relock those manually. 
  2. Test a restored version of my Master board, to make sure that 1. all items are still ‘protected locked’ and 2. most/all of my edits were captured. 
  3. Once I select that restored version, make sure that it can be properly duplicated!!! 
  4. If it can be duplicated as normal, then I’ll be stuck using that one as my brand new Master board, and I’ll have to send out that link to my participants. 

Does that plan sound like the best one to you? Always appreciate any ideas and insights, and sorry for these long messages. 

And finally, I’ll ask this: If you provide support by Zoom/phone, where I could show you the entire training process (much like how I wrote in a prior post -- three part series located on a master board, with three separate prep-work boards that are embedded within) then I’d love a second set of eyes to help! I’ll be doing similar multi-part sessions (different content; similar setup) for both graduate students as well as this same client very soon. 

Userlevel 7
Badge +7

@Anne Scarlett I think it sounds like a good idea to abandon the idea of having the same link. Next step would be to rethink the whole “master board” approach, if possible. 🙂

Userlevel 7
Badge +12

@Anne Scarlett - It sounds like you have a plan. Hopefully restoring a previous version will help.

My apologies that you had trouble with undoing the “Unlock all” to get back to protected lock - I had tested this quickly and it did work for me:

Perhaps that was a certain object type in your mix that was causing issue.

As for a Zoom call, I have done that in the past, but we have a 5 ½ month old baby and my time is not my own these days, so scheduling a time becomes very difficult - the asynchronous format of these posts is better format for me.

Userlevel 2

Hi guys! @Robert Johnson Thanks for showing little demo on unlock all and undo, in order to revert to the protected lock. I am baffled why it didn’t work for me, but I guess there must be some specific object causing the issue, as you said.  Also, totally understand about the inability to have a sync discussion about my workshop setups! Congrats on your new babe!

@Henrik Ståhl Thanks for your help as well! Question: What makes the ‘master board’ idea a bad one, when considering that these are folks super new to Miro, and want to have a ‘one stop spot’ for future reference to all our work together? (Keeping in mind that the structure is this:

>One big workshop, delivered in three separate 1.5 hour chunks (to avoid zoom fatigue, etc, per their request). 

>Prep/post work for each of the three chunks (for a total of three “homework” experiences). 

Without a ‘master board’, the poor attendees and/or students are stuck with six separate boards! That seems unwieldy and messy, especially for people who are not Miro-savvy. Versus a ‘master board’, where the entire workshop is collected in one spot, including the embedded homework boards. I see the master board as a perfect collection point, and also a great launching pad to revisit the homework boards later on. So I’m very interested in how you would recommend designing the overall experience? 

By the way, guys, here’s what I ended up doing:

-Used one of my ‘duplicates’ from earlier on Friday. This will be the ‘newMaster’ -- which sadly means a new fresh link.  But, it was better than using a prior version from history--I couldn’t figure out which one would have the protected locks intact, for one thing. Plus, I don’t like that the ‘history’ versions don’t have previews. 

-Manually made all the changes from the original master onto the ‘newMaster’. This was a big drag. 

-So now---I’m finally back to where I need to be. My ‘newMaster’ is duplicate-able, so far at least. It takes forever, but it does work. 

Thanks again for your time and attention! 

Userlevel 7
Badge +7

@Anne Scarlett It’s difficult to give you a thorough answer without having seen the boards, but based on what you’ve told so far I think that:

  1. the master board is too large with too many objects, and
  2. duplicating it isn’t a very good way to save backups.

Downloading the boards as .rtb files is a better solution for #2 (you could then name the files with the date you saved them and add notes in a separate document placed in the same folder). For #1, just like @Robert Johnson points out, I think you should re-evaluate the option of splitting the content into different boards and embedding boards within boards. It doesn’t necessarily have to result in six boards – the prep/post work could potentially be a single board, for example.

Another thing I notice when looking at your screenshot: You’re at 2% zoom size, and it seems like the board is optimized for a pretty low zoom size percentage. In my experience, that sometimes comes with some quirky side effects.

Userlevel 2

@Robert Johnson Hi! Hope this comment belongs in this same thread, since we covered the topic of “unlock all” with the hope of “undo” so that it would “relock all--in protected mode as it was prior”. 

As you know, that didn’t work for me last week. (Reference our prior notes). 

Yesterday, I did something stupid. I selected a group of items, and clicked “unlock all” thinking that it would only unlock the items I had selected. Unfortunately, it unlocked my entire massive board. SO, then I crossed my fingers that this time I could “undo” the “unlock all”, reverting everything back to protected lock.  Yet again, it didn’t work. About ¾ of the items reverted to “lock” but not “protected lock”. And then some of the other items that I know with certainty were locked prior, did not lock at all. 

Because I absolutely cannot change my master board link for a second time (it would really miff my users), I had no choice but to spend a very long time going through one by one to protect and re-lock and get my board back to where it was because I did the the stupid “unlock all” move. 

I’ve just tried to search about “unlock all”. Am I the only one with the problem of not being able to undo that action and get it to go back properly?   One thing is for sure--until I better understand that feature, I will definitely not be able to use it again! LMK and thanks for listening! 

Userlevel 7
Badge +12

@Anne Scarlett 

Yesterday, I did something stupid. I selected a group of items, and clicked “unlock all” thinking that it would only unlock the items I had selected. Unfortunately, it unlocked my entire massive board.

it sounds like you right-clicked on the a blank spot on the Miro board as that is the only way--that I am aware of--to get to the Unlock all action.

For example, if I select a group of object, there is no Unlock all option in the context menu, or if I right-click on the group of objects:


If you are seeing something different, please share a screenshot or screen recording.

I’ve just had the same problem. I’m able to Duplicate or Make a Copy of other boards, just not this specific one. In the end I downloaded a backup and then immediately imported that backup. Seems to have had the desired effect.