Sharing Permission Menu

  • 12 January 2023
  • 6 replies

My current Sharing Permission Menu looks like this: 

BUT I need it to look like this: 
What can I do to have it look like this (photo below) because I am logged in as the Team Admin. 


6 replies

Userlevel 7
Badge +12

@Ha-Quyen Nguyen - My first thought would be that your boards are part of an Enterprise Plan and your Miro Company Admin(s) have restricted your sharing permissions - more on this in the Sharing policy on Enterprise plan  in the following help center article →

If you are not on the Enterprise Plan, which plan do you have and how are you accessing Miro? (e.g., Mac/Windows, browser/desktop app/tablet app/etc.).

Hi Robert, 

I am our Company Admin so I don’t think my sharing permissions should be restricted? We have the Started Plan and I use Google Chrome to to access Miro. Any advice on how I can have full access to my sharing permissions? 

Userlevel 7
Badge +12

@Ha-Quyen Nguyen - Thanks for confirming that you are on the Stater Plan - there would be no such policy on that plan.

The most likely culprit now is that a browser extension is blocking some of the UI elements. I would suggest trying

  • an Incognito browser window (or disabling all browser extensions)
  • clearing your browser cache
  • or the Miro desktop app

Hi Robert, 


I tried the Incognito browser and an Internet Explorer browser and it worked BUT my Google Chrome browser is still not showing the full sharing permissions even though I cleared my cache. Quite odd… 

Userlevel 7
Badge +12

Did you try disabling all browser extensions? You can see extensions by browsing to this location in a new tab: chrome://extensions/

It seems like the Ad Blocker was the reason I was having the issue! I disabled it and the problem has been fixed. Thank you so much!