[RESOLVED] Miro dashboard won't load

I’m new to Miro - just signed up but for 2 days have still not been able to log in - the Miro dashboard is on a perpetual loading mode. 

Marina 3 years ago

Hi all, 

This issue has been fixed. Could you please check if you can access the dashboard now?

View original

This topic has been closed for comments

35 replies

Userlevel 7
Badge +5

Hi @Trevor Nelson,

I’m sorry to hear this. I’ve gone ahead and converted your message into a support ticket so that the team can investigate the case. They will get back to you via email.

Thank you for providing all the details!

@Kiron Bondale - I am also experiencing this problem. I am on a new Macbook Pro running the most up to date version of Chrome. I signed up for an account yesterday and setup some test dashboards, but when I go to login and access them today I get stuck on the loading M of Doom and can’t access a dashboard.


For the first time ever I opened Safari and it works fine. I tried in a Chrome incognito browser and it still fails to load. I tried grabbing my URL from Safari for a specific dashboard to bypass the menu area and it still wouldn’t load. Hard refresh also doesn’t help.


Three warnings appeared in console, but no errors:

  • RetryPromise was called with "waitUntilOnline" option, but CONNECTION_PROVIDER is not defined. You can set the provider globally via "setConnectionProvider" method.
  • DevTools failed to load SourceMap: Could not load content for https://miro.com/app/static/https:/miro.com/app/static/applicationInlineEntry.3a8edf7357471e5f0fd0.js.map: HTTP error: status code 403, net::ERR_HTTP_RESPONSE_CODE_FAILURE
  • DevTools failed to load SourceMap: Could not load content for https://miro.com/app/static/lazy-local-storage.c9153e786faeb6942c4f.js.map: HTTP error: status code 403, net::ERR_HTTP_RESPONSE_CODE_FAILURE

@Kiron Bondale  Thanks for the suggestion and I can appreciate how that could be the root cause - but that seems to me quite a heavy-handed solution for a specific Miro problem. I might just wait to see if the issue fixes itself and use Safari/Miro app in the short term.

Userlevel 7
Badge +6

@RobinA -

I hate to ask but could you try uninstalling and reinstalling Chrome? You mentioned you had rebooted the computer and I’m wondering if there were any updates to Chrome which somehow corrupted it...


I cannot go to a specific URL, neither can I grab the URL link from Safari and paste it into Chrome to see it work.

Userlevel 7
Badge +6

@RobinA -

Can you try logging directly into a specific board via Chrome? Grab the URL from Safari for one of your boards and then try that URL…

Can you confirm that you can log in from Chrome from a different device such as another person’s computer or a smartphone web browser?


Hi, I have a similar issue with running Miro on Chrome on my MacBook pro. Everything was fine until a computer restart, since then all my Chrome tabs with Miro have been running with the spinning “M” and have not loaded yet.

I can log in from the app and from Safari. I reset application data in the app and also cleared my browsing history in Chrome, neither seem to solve the issue.


I also tried to log in via “Incognito mode” in Chrome and went through the sign in journey, but get the spinning “M” there as well.


Any thoughts on what might be causing this?

Hi Kiron,

It seemed to resolve itself. I restarted again and it loads fine now. Bit worrying - hope it is stable.

Userlevel 7
Badge +6

@Dean Birkett -

  1. If you are using Chrome to access Miro, can you try logging in via incognito mode and see if that works?
  2. Can you try accessing it via the desktop app?


Okay, I’m getting nervous. I’m running an online workshop in a week and today Miro has decided to just constantly load. I cannot access the dashboard, nor can I access via the direct link.

@Kiron Bondale It’s a macbook pro - less than a year old. I should add that it used to work and stopped today. I was hoping there was an update I hadn’t applied, but didn’t see any way to update the app. 

Speaking of updating the app, I just looked in help and “reset application data” and I’m all set. Thanks for the help. 

Userlevel 7
Badge +6

@Austin Brown -

How are you accessing it - have you confirmed that the tablet/phone/computer meets the requirements for the app (https://help.miro.com/hc/en-us/articles/360017572794-Supported-Devices and https://help.miro.com/hc/en-us/articles/360017731553-System-Requirements)?


The app doesn’t launch for me - just sits on the M animation. I was able to log into miro on the web and see my boards, but i prefer to use the miro app when possible. Any idea what could be causing the miro app to get “stuck” loading/launching?

My problem has been solved and now I’m working with Miro as usual :) Thank you! 

Logging out and back in solved the problem in my case, hopefully, helps to somebody else.

Userlevel 4

Thanks a lot for your understanding, @Evgeniy Petrenko :raised_hands:

I also raised the priority of your ticket so hopefully we can find the resolution ASAP :fingers_crossed:

Thanks for your reply! It’s very important to understand that you guys are in touch with my problem and now I’m feeling it. 

I understand that I don’t pay right now for Premium Support, because I haven’t needed yet this commitment according to your support. 

Good luck with your significant backlog! Stay strong :) 


Userlevel 4

Hi @Evgeniy Petrenko :wave:


I’m very sorry to hear we didn’t meet your expectations. As you noticed in my post, we indeed prioritized the support for our paying users. Still, the amount of our backlog is so significant that we can’t be that swift as we were before the COVID situation.


I kindly ask you not to perceive this as an excuse — at the end of the day, it’s our responsibility to provide the best possible customer experience. On the other hand, within the current circumstances, we can’t commit to any specific SLAs even for paying users. The only exception is our Premium Support customers — they’re obviously paying for this commitment  :slight_smile:


Anyway, we’re doing our best to get back on track as soon as it’s possible. Apologies for the inconvenience one more time!


Head of Customer Support @ Miro

Hi @Evgeniy Petrenko and @Tamika, I’m so sorry it takes that long for the Support team to reply to your tickets. Our Head of Customer Support shared the current situation in the team in this post

I have asked the team to have a look at the tickets you’ve submitted, hopefully, the agents will be able to get back to you soon.

Thank you for your understanding!

Thank you Marina! I’ve got reply by Customer Support Agent. I hope we will find solution.

I’ve read this post and I’m paying user, not a free, so that’s why I waited for quicker response. 

Userlevel 7
Badge +5

Hi @Evgeniy Petrenko and @Tamika, I’m so sorry it takes that long for the Support team to reply to your tickets. Our Head of Customer Support shared the current situation in the team in this post

I have asked the team to have a look at the tickets you’ve submitted, hopefully, the agents will be able to get back to you soon.

Thank you for your understanding!

Same issue for me! I am on paid subscription and although I can use direct link to access a board I am unable to start a new project!

I need this fixed most urgently please. As with above have tried everything and sent support emails and no response!

I have the same issue. Moreover, I sent email to support@miro.com previous week and still have no any answers. I have infinitive loading process when I’m trying to reach this page: https://miro.com/app/dashboard/

But if I try to use a direct link to get the board it works. But I can’t find all my boards without Dashboard, and also this issue block my working processes. 


What should I do?


I use:

Safari, Firefox - Latest Version

Mobile iOS app - Latest Version

Desktop Mac OS - Latest Version


All of them don’t work. I assume, can it be related to my internet provider that I use? As I’m WFH because of quarantine I wasn’t able to test it with another internet, but I’ve tried LTE and home internet, and also using two different proxy.

As it happened to me before like 3 weeks ago, Miro is magically now working well today without doing anything and without trying to copy and past Safari'URL.

I have a colleague that had the same issue weeks ago and it was magically solved as well. Interesting


Thanks anyways @Kiron Bondale 



Userlevel 7
Badge +6

@Gus Irisa -

As a workaround, can you copy the URL of a board you have access to from a Safari session and then paste that URL into Chrome and see if it launches correctly? If it does close Chrome and try to get back into Miro with it and see what happens…


I have the same problem in Chrome Version 81.0.4044.138 (Official Build) (64-bit). Cleared browser data for 7 days and still in the infinite loop and never load the dashboard

It is working in Safari though