PDF import is blank

  • 16 November 2022
  • 5 replies


I have been using Miro for a while, but today when I loaded in some PDF’s (same way as before) the PDF’s are loading but then turning white. If I double click them then a window pops up with the viewable file (so I know the information is there, but you cant see it on the board


5 replies

Userlevel 4
Badge +1

Hi @Sean Taggart, thanks for reporting this issue! We’ve tried reproducing this behavior but haven’t been able to, unfortunately. Can you provide us with the following information?

  1. The device OS and the browser/app version you’re using Miro on. If your setup isn’t supported by Miro, switch to a supported one and check the situation there.
  2. Do any of these troubleshooting steps help?
  3. What sort of content does the imported PDF file contain (tables/images/etc.)?

If this doesn’t help, let me know. I’ll convert this post into a ticket so we could investigate this further. 🔧 

PDF posting as blank

This is one of the files not working. I have tested uploading it from multiple devices and browsers. 

Used, chrome, firefox, win 10 and 11. 

Userlevel 4
Badge +1

Thanks for the additional information, @Sean Taggart!

We’ve created a ticket for you to investigate this further and will update you soon via email, so stay tuned!

Still have the same problem on iOS (iPad and iPhone) - App and Website. Did you find any solutions?

Hey, Sean.
I had the same issue as you did.
I tried to optimize my PDF file and make it compatible with the older PDF versions and it helped.
I am using Foxit PDF reader and here are the settings that I used to optimize the file. I hope it helps