My board got deleted and I am not an admin anymore!

I have been working on this board for the past 2 weeks, it was a competitive analysis.
This board was opened in my tabs for the past 2 weeks and suddenly after a few days ago I entered my board and saw a message that I need to create a new team (?), I don’t remember what I choose but it suddenly deleted my board and from then I can’t access it because it says that i need permission from the admin (which is originally me). 
I contacted support but they also say that this is not my board and I need to contact the admin (which is me)! are you serious??? 
I have spent so much time and work on this board and now I have to do it again because of errors in your system! 
Luckily I have a screenshot from my board that I took before this incident happened but support still says that its not mine! what do I need to do more to prove that this is my board?
Even if I enter my recent templates I can see that my recent one was “Visual Table”, the one that I used for my competitive analysis board!


Please return me back my board! 


11 replies

Userlevel 7
Badge +12

@Shani - Sorry to hear that, but if support is unable to do anything the community forum definitely won’t be able to resolve the issue. All we can do is offer a possibly explanation and advice moving forward.

It sounds like you were a member of a Free Plan team along with at least one other person who had the role of Team Admin. In this scenario, it doesn’t matter if you initially created the board and were a Team Admin - any Team Admin can delete any and all other team members and taking ownership of their boards in the process. So that support as told you is true - you are not a team member and therefore definitely not the board owner, therefore their is nothing they can do to help you. 

What happens if you try to load/browse to the board in your browser (the link should still be in your history. Do you see a message like this?


If you do create a new Free Plan team and continue to user Miro, there are three suggestions I have for you:

#1 - Team Permissions

Set the following, so that, if you add other members to your team, they cannot invite any other team members to your team:


#2 - Do NOT make any other team members “Team Admin”


#3 - Change the settings of any boards that you do NOT want team members to make any changes to

While you can’t have private boards in a Free Plan team, you can at least change the permissions so that it is in view-only mode for everyone except for yourself:


Yes, I do see a message like this. I tried Request access but I didn’t get any email. 
I was the only admin!!! in this board, nobody else was with me! 

Userlevel 7
Badge +12

@Shani - Have you ever created a Miro account with an email address other than the one you are currently using?

I was the only admin!!! in this board

Boards do not have “admins”.

Were you the only team member in the team where the board was located?

Did you ever collaborate on any Miro boards with other people, e.g., had you ever shared a link to a board that was in your account with anyone else?

Example - if you ever opened a board’s Share settings and use the following Copy invite link button, as soon as someone clicked on that button, they were added as a team member to your team:


Or… another question for you. When you first created a Miro account, did you just go to and sign up, OR did someone say, “hey, try out Miro.. work on this board me me/us, and someone sent you a link to a board?

Nope! this is my only Miro account ever (I did try checking my other email but it was not registered to Miro).

Yes, sorry for my misunderstanding. I was the only team member in my team.

I never collaborated with any other people, never shared my link with anyone. 

When I first created my account I just went to Miro and signed up.


Thank you for trying to help me!

Userlevel 7
Badge +12

@Shani - Another question:


@Robert Johnson 

Yes, just one team. 
Even when I was working on my deleted board I had only one team. 


Userlevel 7
Badge +12

@Shani - Do you use a password with your account or, if using Google, did you use the Sign up with Google option? Perhaps someone gained access via your email.

@Robert Johnson 

Even you can see that in my screenshot it was just me. (sorry for the poor quality ugh).

I am using a password with my account, not using google. 


Userlevel 7
Badge +12

@Shani - That screenshot only shows that you were the only person on the board at that point in time. There could be 100 people who are a part of the team, but on you were on the board.

My only suggestion now is that you should share a link to this post with Miro support to see if there is perhaps any more information here that they may be able to use/re-consider.

You can find your support ticket history by going to the following page, signing in, and then selecting My activities:

I would also suggest changing your Miro account password.

Thanks, I will do that.

Hi! I have had the exact same problem, was working on a board, without any team members 

I worked on it for hours and I cannot enter, also when I ask for access to my account...

This is the link to the board:

and this is the image suddenly appearing: