Mouse navigation not working properly on ipad

  • 2 January 2021
  • 20 replies

Userlevel 1

Is anyone else experiencing problems with the mouse support on iPad?
I am mainly referring to the zoom function that should work with the mouse wheel. On my iPad Pro 12.9” 3rd generation and a Logitech MX Anywhere 2 I am not able to make it work.

Any suggestion on how to fix it or anyone with the same issue? 


20 replies

Userlevel 7
Badge +12

@Paolo - The board panning up/down when using the mouse wheel is usually an indication that your Miro Navigation Mode is in Trackpad or--in your case--Touchscreen mode. Without knowing if you are using a browser or the Miro Tablet app, my only suggestion here is to check your Navigation Settings and see if you can change it to Mouse


Userlevel 1

Hi @Robert Johnson, thank you for your answer! 
I did exactly what you illustrated as I was aware of the setting, but still it does not work.
I have tried different troubleshooting: 
• I have tried to use it on the web app, running on Safari on iPad and in that case also, the mouse wheel doesn’t allow me to zoom in nor out. 

• I tried to uninstall the app and reinstall it. Nothing changed.  

• I have also checked in the iOS Settings and I don’t seem to find anything that might cause the issue. 

I have a question, in your video you show how to change the navigation mode, but did it work afterwards? Is it currently working for you and with what kind of mouse?  
I am wondering if it is a problem related to the specific Logitech mouse at this point.

Thank you again!

I will try with a wired mouse and see if that makes a difference.
Unfortunately I do not have a trackpad to check wether that works.

Edit 2:
Tried with wired mouse (also from Logitech unfortunately) but still the mouse mode does not allow zoom in and out with scroll wheel. 

Userlevel 7
Badge +12

@Paolo - What about this setting?

Note: I don’t have an iPad and can’t try this… just took it off of the internet:

Customizing the Scroll Wheel on a Mouse on an iPad / in iOS

  1. In iOS, open the Settings.
  2. Select General.
  3. Tap Trackpad & Mouse.
  4. Turn off Natural Scrolling.

This lets you change it so if you scroll directions on the mouse. If it’s turned off, scrolling the wheel up scrolls the screen up.


Userlevel 1

Yep, tried that too. :/  Nothing. I am asking some friends to try on their iPads and see what happens. 
Thank you for your time! :) 

Userlevel 7
Badge +12

@Paolo - To answer your question, I have never had a problem with my mouse wheel not scrolling. I am using a Logitech M325 on Windows 10 Home (2004) and it works in Chrome, Edge, Firefox, and the Miro 64-bit Windows app. I have never tried it on any kind of tablet. And to try it for the first time ever, I just plugged in my Logitech mouse receiver into my Android 10 phone (Galaxy S10) via  a USB Type-C to USB Type-A and the wheel pans the board up and down when the wheel is scrolled in the Miro mobile app - however, there does not appear to be an Android OS setting to control the wheel action - plus the Miro mobile app doesn’t appear to support the changing of navigation modes. 

So… I opened the Chrome mobile browser and set to “Desktop site” to force the full version of Miro in a mobile browser and the board detected my Touchscreen and Mouse (and even showed Trackpad, presumably because of my phone’s touchscreen?)

And the mouse wheel zooms in/out:


Userlevel 1

Oh that is very interesting! I have not tried on Chrome for iOS and also I have not tried on Safari forcing desktop mode either. So I will try that now. 
I have asked a friend that owns the newest iPad Pro 11” and she also didn’t managed to use the wheel-scroll to zoom in and out. So it seems just a common issue at this point. She’s also using a Logitech mouse but another model than mine.  

To me it seems that the mode is just not changing, as it works exactly in the same way no matter what mode I apply. On iOS/iPad OS anyways. 
I’ll update this post after checking Miro running Chrome and Safari with forced desktop mode on.

Userlevel 1

So, I created a new post to make it easier to follow. 

I have tried on Chrome, Firefox and Safari with “forced” desktop mode (Desktop mode is actually the default in iPad OS) and it presents the same issues.

At this point I would momentarily give up and attribute the issue to either a bug, a bad implementation of the feature in iPad OS or a problem on the OS side itself.
After all, the mouse support on iPad OS is fairly recent I can imagine being still some support and compatibility issues. I cannot be sure… would be nice to hear form some insider in Miro :)

I am new to the platform but at this point it feels like I should file a bug report or something like that. I am not sure how to do that tho. I need to look it up.

Thank you @Robert Johnson for your help! I will try to update this conversation if something new comes up or if the problem get solved. 

Peace ✌️ 



I have an iPad 12.9”, i have installed the Miro app, i have changed the navigation mode to Mouse, but i am not able to move objects as well as i am not able to pan around the board. I am using an Apple Magic Mouse. Also i am not able to do multiple objects select using the mouse.


Although i am able to add objects, right click on the canvas, edit the objects using the Mouse.


Everything is working if i set the Navigation mode as Touchscreen.

Userlevel 7
Badge +5

Hi @leovipin1,

We’ve just checked the mouse with iPad, and everything is working as expected for us.

Just to confirm - do you click the canvas and drag to pan around the board? Also, have you enabled the Select tool (as opposed to the Hand tool) in the toolbar to select and move objects? In order to select multiple objects with the mouse, you’ll need a keyboard and to hold down the Shift button.

If these gestures do not work for you, could you please make a screen recording and send it to the Support team? And let them know your OS version.



Yes i click the canvas and drag to pan around. Yes i have enabled the select tool in the toolbar. But still the same case.



I actually have the same issue as well, just bought a mouse recently to try out the workflow with miro. Mouse scroll is not detected for miro on apple ipad across app/browserl; no matter what setting is in place. 

Could the team please look into this?


Thank you very much!



Shi yuan

Same issue! I’ve tried all of the solutions listed above and no success. 

Hi, same issue here, Miro app on iPad Pro, using a new Magic Mouse 2, navigation mode set to mouse. I can pan the canvas by click and drag, but zoom via scroll on the mouse does not work :/


I experience the same issue, but also found some weird workaround (which does not fulfill all the needs but I thought it’s something worth mentioning here)


First of all, I disable all the customization of iPad mouse features including assistive touch, then I could navigate by clicking the left or middle button. But I still could not zoom in/out with wheel, which is super inconvenient.

But I discovered that when I select an object and double click to be able to edit it, then I could somehow zoom in/out. But when I deselect the object, the wheel stops working again.


I try to select something when I want to zoom in/out but it creates random empty boxes everywhere and it’s really annoying, so I also try to work with shortcuts (command+2 for example)


I hope this helps some people, but in any case this is a major bug since zoom in/out is one of the most basic motion you need, so I hope Miro team handles this quickly.

Hi, My MX logitech have a same problem with Miro and also gg sheet. How to fix it?

Hi I have the same problems, and even worse, I can’t select, or click on objects in the Miro board, it’s really frustrated experience using miso on IPad (pro 12) hope the experience can be improved soon :( 

Same experience here with a logi MX Anywhere 2s. I can’t select anything on the canvas, or zoom or anything. I am able to select some menu items, but not others. I had to go and tap the setting drop down, for example, but i could then navigate the submenus.

Hope this is resolved soon.

I have the same problem. 

my devices are iPad Mini 6 and Logitech Anywhere MX3. 

I found out that if I click on search zoom works perfectly well. But after search is closed zoom stops working too. 

Please take a look on this bug. This is the only reason I need a PC at this moment and my life would become much easier if this is solved. 

Thank you. 

I have the same problem here.


My devices are:

iPad Air 5

Logitech MX Master


I tried many things, and the only workaround that works is to use Miro on Safari. Then everything is fine. 

I did the same with Google Docs and Sheets as they are unusuable on an external display. I can’t believe they can’t make such simple things right.