I can't load my Miro board

  • 29 October 2021
  • 13 replies

I cannot get on to any of my Miro boards I keep getting stuck at the loading page for HOURS. I have a project due Saturday and I don’t know what to do. I’ve looked at all the discussion boards on this and nothing is working. I’ve tried:

  • switching browsers (Safari and Google Chrome)
  • clearing cache and cookies
  • restarting my computer
  • trying incognito mode
  • downloading the desktop app - Desktop app does the same thing
  • trying on a different computer

13 replies

Userlevel 7
Badge +12

When I hear that someone can load a Miro dashboard, but not the boards themselves, it usually means  that it is network - VPN, firewall (probably configured right within a router/modem, if you have tried another device) - I would have a read through this article:

Are you able to try a completely different network, e.g., use your phone’s hotspot?

Userlevel 7
Badge +12

Or try using the Chrome mobile browser with the Desktop site mode enabled - this should load a board just like you are on your desktop/laptop - handy when you need to complete an action that isn’t available in the Mobile app.


@Robert Johnson I tried on my phones hotspot and still stuck loading.

@Robert Johnson Using Chrome and doing desktop site works but i can't exactly complete my project on my phone. 

Userlevel 7
Badge +12

@Bridget Kacprzyk - At least we know that a different device on a different network (presuming your phone was not on your wi-fi) works, so it likely has nothing to do with your Miro account.

What about installing the Firefox browser?

Userlevel 7
Badge +12

And what happens if you create a new board - will that load?

You could also try Duplicating one of your boards that won’t load to see if the duplicate/copy will load.

@Robert Johnson it works on the Miro app and the Chrome desktop site on my Wifi so the issue isn't my home network

Userlevel 7
Badge +12

Yes, but your phone may have flipped over to use the cell network of the wifi wasn't getting through.

Try putting your phone in airplane mode, then turn your wi-fi on, and try again. If it works, that should rule out your wi-fi. Then it could be something on your Mac.

What is the other computer that you tried?

Userlevel 7
Badge +12

@Bridget Kacprzyk - Did you try the WebSockets test site that is referenced in the Miro Help Center article that I sent you?



The Miro application - specifically the board pages - requires WebSocket connections. If you're having issues opening your boards but the dashboard and the settings pages open as expected this might mean that your connection does not support WebSockets. 

To test your connection, please open this website.

If the Websockets are identified, you'll see the following message:



Did you every get this resolved? It has happed to me a number of time and I give up for a few days and try again and it starts working again. Frustrating to say the least.

Any update on this? My business partner is having exactly the same problems.

Any updates on this? I had the same problem: was working on a board for hours and hours. Then Miro crashed and now I can't open that board anymore. I can open any other board, except that one. Can't download a backup either. So, is my work lost?

If there is no solution to this, that would be a great reason to never use Miro again.

I’ve experienced this twice the past few weeks. We have A LOT of boards and while I can log in fine, any attempt to access my boards just ends up with indefinite loading indicators.