Frame won't delete

Userlevel 1

There is a persistent frame in the middle of my board. I can’t move it, rename it, or delete it. I have tried both using the options in the ellipsis dropdown in widget above the board and from the frames sidebar. I am setting up a workshop for tomorrow. 



Best answer by Robert Johnson 20 May 2021, 18:18

View original

10 replies

Userlevel 7
Badge +12

@Andrew McKinley - First, thanks for the video - I wish more people would include these!

While this is a bug and should be reported to Miro, surely they won’t resolve it before tomorrow. To get rid of it, try Duplicating the board - there are a number of ways:

  1. Use the board’s ellipsis menu from the dashboard
  2. While the board is open, click on the board title and use the Duplicate button.

More on this in the How to Duplicate a Board Help Center article.

I suspect duplicating will get rid of it as each object is ultimately referenced back to a board ID in some database table. A new board ID should clear it.

Userlevel 7
Badge +12

@Andrew McKinley - I would suggest reporting this to Miro support right away - also include a link to the problem board in your support ticket.

It would be helpful too if you could pop back here and let us know what the support team tells you.

How to Contact Miro Support

The support form can also be found here: learning center → Get help → Support


Userlevel 1

Thank you @Robert Johnson I have reported it and will post something here when I get a reply.

Userlevel 7
Badge +12

@Andrew McKinley - Were you able to delete the frame from the duplicated board?

Userlevel 7
Badge +12

@Andrew McKinley - I see you are using the Miro desktop app. You could try resetting the application data as per the Desktop App Help Center article:

Miro for Mac:

Click Miro in the top menu and choose Reset application data as shown in the screenshot below:




I would also suggest trying to load the board in Safari or Chrome, to see if a fresh cache helps.

Userlevel 1

Circling back here. I was able to duplicate the board and set it up in time for the workshop. Thank you @Robert Johnson for your help.

The following day, when I relaunched the desktop Miro app after restarting my Mac, I checked on the problem board and the persistent frame was gone. Your last point about resetting the application data probably would have corrected it.   

Btw, Danil (Miro Support & Help Center) checked in pretty quickly as well. Appreciate all the help. Thanks again. 

Userlevel 7
Badge +12

@Andrew McKinley - Thanks for the update and for letting us know that the suggestions helped.

This persistent-objects issue seems to happen most often with Cards, but as we've just learned it can happen with any object. Glad to hear you were able to resolve it before your workshop.

HelloI have the same problem reported in this topic.There are 3 frames on my dashboard and I can't delete them.I cleared the cache and tried some features that I read here in the community, but with no success.Can someone from the support team help me?


Userlevel 7
Badge +6

@Ubirajara Carratu -

You can open a Miro support request here: Submit a request – Miro Support & Help Center


As a note, this still occurs.