Every time I try to use the middle click to navigate the scene, it would automatically paste something

  • 22 October 2021
  • 18 replies
  • 2569 views

Hi, I’m using Google Chrome in Ubuntu 20.04 to access Miro. Every time I try to use the middle click to navigate the scene, it would automatically paste something. Is there anyway to disable the middle click to paste function in Miro? 


18 replies

Userlevel 7
Badge +12

@Jianeng Wang - This is interesting to me as I never knew until now that I could middle-click my mouse wheel to pan the board, even when I am in select mode.
What I am not able to recreate is a paste by clicking down of my wheel on my mouse - even if I double- or triple-click - nothing happens. I tested this Chrome on Windows 64-bit, and in Firefox and Edge.

Perhaps this paste action is controlled by your OS?

Same issue here - and very problematic. ps: I use a chromebook. I never had this issue until today, so it is recent issue. I have tested several mice, and the behavior is the same. I wonder if the behaviour has been recently updated?

Actually, it seems like a lot more than just the middle click has changed. I am like a toddler trying to learn how to walk again - but a toddler with a 5pm deadline…

If someone has some clarity about what happened, I am very curious! Secretely hoping I can set settings back to what it was a few days ago...

Same here. I started working with Miro a week ago. The first four days went smooth (using a mouse on my desktop machine). Then something changed and now my entire project has random snippets scattered around from pasting with the middle wheel.

Using a recent Firefox (v93.0) a 6-button mouse (only using left (primary) + middle/wheel + right in Miro) with the “mouse”-setting.

I used to pan using the middle button. But now every time I do this, it pastes whatever is in my clipboard.

Would be cool it one could configure the mouse’s behavior in more detail.

Also, I just read a on-screen tip about being able to pan with the right mouse button and box-selecting things with the left button. I have two projects open: one of them works as described, but the other one still pans with the left and the right button only opens the context menu. Both of them zoom on scroll, so I’d assume they’re both in the “mouse” setting.

I personally prefer using the mouse wheel for all navigational functions (panning, zooming). The left is for modification (dragging and maybe box-selecting) and the right is extra-stuff (context menu). But having the box selection on the right mouse button would also be ok for be. Still better than pressing shift + left mouse.

Forgot to mention that I’m running Linux Mint. The middle-button-paste function seems to come from the OS (as @Robert Johnson already ruggested). I never noticed or used that feature and I’ll try to switch it off.

It’s still interesting that this never interfered with Miro until the recent week.

Yeha this recent change has mad Miro almost unusable - if we could toggle this option on or off that would be apprecaited. Demoing to clients and just contantly pasting into the doc. 

I was able to disable the paste in middle-click feature using `gnome-tweaks` on my machine. Not sure if this is a solution or a workaround.

I noticed something else today which might be related: when I double double-click a text in order to edit it, the cursor becomes attached to the background (moving the mouse pans the workspace around). Letting it go is somewhat hard (atm I wildly click and press Esc until everything is back to normal). Someone™️ should have a look at this, too.

Same problem for me :

  • pasting involuntarily at each middle click (for pan)
  • when copy/paste cards, the new one overwrite the old instead of creating a new one on the side
  • when editing text of a card, the whole view is moving when I’m moving my mouse cursor (to make the cursor stay on the card somehow)

    Hope it will be solved soon !
Userlevel 7
Badge +6

Folks - 

I’d suggest that someone open a support request with Miro here and provide the full details on the previous and current behavior as well as the system and browser configuration you are using: Submit a request – Miro Support & Help Center

Kiron

I’m currently suffering from the same - Ubuntu 20.04, chrome version 95.0.4638.54

As a workaround in firefox, you can disable the browser-wide setting for middle click to paste by going to `about:config` and setting `middlemouse.paste=false`

I’m currently suffering from the same - Ubuntu 20.04, chrome version 95.0.4638.54

Same issue here. Other collegues are using windows with the same problem, so I guess it is not an “ubuntu” issue. 

The middle mouse click is a normal Xorg( and others linux displaying server) feature and works as clipboard for highlighted text. This is a very nifty and good feature.  Sadly, it appears that miro changed to always copy content from the clipboard when the key combination/button  is pressed. IMO they should change it back to only copy content when you create a textfield (or atleast give us the ability to disable it for their site),  as disabling the paste generally or in firefox/chrome is not a valid option (atleast for me). And without disabling it the site is virtually unusable.

for people who want to disable it generally under ubuntu: https://askubuntu.com/questions/4507/how-do-i-disable-middle-mouse-button-click-paste

or only in firefox:

  • open a new tab
  • type: about:config
  • Accept the prompt
  • type middlemouse.paste
  • change value “true” to “false” (double click or switch on the right side)

Same problem here.

Ubuntu 20.04, Firefox 94

Same issue here. I would like to disable this automatic past functionality to miro. 

In Ubuntu Budgie can disable this action searching and open ”Tweaks” and disable the next option: 
scs
 

 

Yeah, I am suffering from the same stuff - middle mouse click. It began about a month ago…

I am using ubuntu 20 and Vivaldi (with chrome inside I guess)

I had a support ticket open with Miro about this issue and just received notification that it is now fixed.

As far as I can tell this is indeed the case (re-login might be necessary to receive the code change).

Reply