Copy & paste not working

  • 31 March 2020
  • 22 replies

Userlevel 2

I copy image from Photoshop and it appears in Miro. Now i want to copy it back but Ctrl+C do not copy image back to clipboard. Its very hard for concept artist use Miro as reference board/mood board tool because its hard to copy content back from it to professional software.

22 replies

Userlevel 7
Badge +5

Hey @Alexander Vinogradov

Thanks for sharing your use case! You are right, it doesn’t work the way you describe, but you can try to export the image. I understand that it requires more clicks though.

Userlevel 2

@Marina It will not work because when you click to download - it loses the name of the picture and is always “image.png” which makes the operating system show conflicting names popup.

Userlevel 1

Copy-paste does not work correctly in the app, which sucks. I noticed that the function does not work in the Miro app for Mac OS, but it works in the Miro web interface (Firefox for Mac OS). So, it seems it’s not a feature, but a bug after all?

Userlevel 7
Badge +9

Hi @i a t ,


could you please send this as a ticket to this link:

Please use the webinterface as a workaround till it will work via the app.


Userlevel 1


Userlevel 1

Hi @i a t ,


could you please send this as a ticket to this link:

Please use the webinterface as a workaround till it will work via the app.


This doesn’t work in the Miro App for Windows or in Chrome/Edge for Windows.  It’s pretty important for me to be able to copy content created in Miro and paste in other apps like Powerpoint, etc, quickly, and saving to an image every time and then importing an image isn’t really viable.

I am also trying to copy from a Miro board I have been working on with a client.  

I have spent several sessions working with a colleague and our client to create high level images in Miro which I now need to copy and paste into a report and presentation, but copy and paste does not work.  

This is such a fundamental requirement for this product! As a business we have only just taken out the paid for subscription for this product and it is incredibly frustrating to realise that I will now need to re-create all of the diagrams in order to use the work that we have done.

Can anyone from Miro advise when this functionality will be available, otherwise my business will need to consider switching to Lucidchart.

Userlevel 1

Not sure what your particular situation is, but the only thing I’ve been able to do so far is copy and past as an image, or leverage something like the snipping tool in Windows to capture as much as you can and place it in your presentation.  Not great as you can’t edit them in any way, but it’s still an option.

Agreed, that this is something we really need.  I realize there are a lot of complexities in software and copying and pasting something that is in more of a proprietary format is hard, but at least an option to export the designs as say a PPTX format so we can work with it that way.  PDF is one thing, but so many people use these designs for PPTX, Google Slides, etc.

Hi jhvmware, how are you able to paste as an image when I copy the item from Miro there is nothing available to paste into another app (see below) and the the only option in Miro appears to be to export to CSV.  I have raised with support who have told me that they have passed my request to the product team to see if they think it should go in the backlog 🙈  

Given that people have been asking for this basic functionality for over 7 months I think they already know the answer to that question.




Still the same story! I cannot paste any element which I’ve copied from another application into MIRO. It seems MIRO uses an own clipboard detached from the WINDOWS clipboard. It ist really frustrating. When I copy an element in MIRO to the clipboard (Ctrl-C) I can paste it in MIRO again (Ctrl-V) but I cannot paste it in PowerPoint for example. The copied element does not appear in the WINDOWS clipboard history. More crazy: When I copy an element from PowerPoint to the WINDOWS clipboard it appears in the clipboard history. I switch to the MIRO board an double click the element in the WINDOWS-clipboard. MIRO pastes an element, but not the one I double-clicked but the last element I copied (Ctrl-C) in the MIRO-board (which never appears in the WINDWOS-clipboard). So I can trigger a paste-action in the MIRO-board via the WINDOWS-clipboard but the really pasted element comes not from the WNDOWS-clipboard but from anywhere in the outerspace (the MIRO-clipboard?).

Userlevel 7
Badge +9


last time I copied content of an application - it worked - was yesterday.

But I have noticed that not any application supports this copying into miro … I have no Idea what is the solution to this.

Here again I post a list of shortcuts that are supported and - depending on the APP - are not supported … and like in my case depending on the program your working with supporting copy and paste and other not …


Thanks Michael,

Some of my colleagues do not have the problem - they can copy-paste pictures between applications and MIRO. Yesterday I found a simple work-around for my problem. If I open the MIRO board in the browser (e.g. chrome) the copy-paste works well. But it does not work if the MIRO board is opened in the MIRO-app. I think the problem is a cache-sync problem between the WINDOWS clipboard and the clipboard used by the MIRO app (seems to be not properly synchronized with the WINDOWS clipboard). 


Is this still not working?  I am a concept artist and I would love to use Miro as my reference guide. Unfortunately not being able to copy and paste pictures, patterns or whatever into photoshop while I work is extremely frustrating.

Please do something about it. It doesn’t work for me if I use Miro in the browser or in the app. Both ways are still not working.

In short: use the exe from Miro Apps.


In details: Paste did not work for me in the app from the Windows store. After two weeks I could not export as PDF, it told me that this function does not work in Edge. Then I read and . Finally, I uninstalled Miro, then downloaded the exe from Miro Apps, and voila, pasting worked, exporting worked.

Userlevel 7
Badge +12

@Dániel Zölei-Szénási - 

I just want to clear something up. There are two flavours of Microsoft Edge:

  1. Legacy
  2. Chromium based

As of January 2020, the first stable version of the new, Chromium-based Microsoft Edge browser was released (version 79). Chromium is an open-source browser project that Google Chrome’s browser is based off, so for the sake of using Miro, I would wager to say that any version higher than 79 of Microsoft Edge will be comparable to Google Chrome - enough that I have been using the new MS Edge on work laptop with Miro and have yet to run into any issues.

So, the new Edge (shortcut looks like this) will work:


The old Edge (shortcut looks like this) will not work:


I am enthusiastic about Miro but there is really a problem with copying content from Miro to other apps. If this is not solved Miro is unworkable for us. We are thinking about integrating Miro into our workflow and getting a company upgrade. But without the possibility of copying it wil be a no go. Really hope Miro solves the issue.

This has been a problem for a long time. Have the issue on Mac using the EXE and browser also. I can download as an image but this does not help in terms of workflow.


Seconding all of the above.

Seconding as well.

I love Miro and it is really the tool I need to sort my thoughts.

But breaking basic functionalities like copy/paste and making your app a dead end for content is really not acceptable.

At least support it for images; should work for whole tables as well.

Copying and Pasting in Miro has been entirely inconsistent for recently, particularly today.  Unfortunately 90% of my work is in Miro at this stage of my workstream and without copy/paste functionality my abilities have come to a sluggish crawl. 

What I’ve encountered throughout all of today, and inconsistency the past: 

  1. Copy / paste does not work AT ALL
  2. Copy no longer works and I can only paste the “last” content copied

I am in the miro app. I am copying and pasting sticky notes, text and shapes. Content created in Miro.  

I have restarted Miro multiple times, which has resolved the copy paste issue for roughly 30 minutes. 

The only work around that I have found is to copy the item as an image. Ctl Shift C on Windows and Cmd Shift C on Mac, will copy it as an image. I was having this issue and had to dig into the shortcuts and try stuff. Hopefully this works for others. 
(For reference I am copying images out of Miro into PowerPoint and Word.)

how is this even a feature and not just a bug?


I would actually _prefer_ to use Ctrl-C/V if it worked. It doesn’t work with objects in Miro, only with external text that I copy into Miro. This is Miro Web on Firefox.