Connection line text no longer editable

  • 23 August 2023
  • 26 replies

Userlevel 2

I have a number of boards that I’m the owner of, yet today I’m no longer able to edit or move the text on my connection lines. Double clicking on the connection line or its text just creates a new text. If I remove the existing connection line and replace it with a new one, I can edit and move the connection line’s text just fine, but the label on any existing connection line is just frozen. 

This is both in the macOS client and in the web interface.

26 replies

Userlevel 1

I’m experiencing the same problem as @Johan Sonck with editing the text on existing connection lines and arrows.

I am facing the same issue, cannot edit text from existing connection lines/arrows.

I am facing the same issue. It started happening today in the morning for all the existing lines with text. You can easily reproduce it when copy-pasting a line with text.

Same here! This is a big issue for our board, as we have many lines with text! New lines with new text work though. 

Same issue here.  

Userlevel 1

We opened a support case with Miro and have been informed that they are aware of the issue and are working to resolve it.

Since 3 days I’m facing the same issue :( I can do everything except updating text on connection line.

Thank you @Chris Wheeldon for opening a support ticket. Could you please update us here as well? Thanks a lot

I am facing the same issue, the way I solved is to create a brand new line.

Guys, get the desktop client! This bug does not exist there!


Same issue here - it’s becoming a real pain in editing the same board back again - especially if I just duplicate the board and need to change a small amount of text in the connecting lines. Tried searching for the text and seeing if that works but nope. There’s no search and replace feature as well yet (separate point). Really waiting for Miro to resolve the issue ASAP!

Same issue here. Especially for connectors I haven’t added.

And I cannot change the text for a connector I created a few minutes ago.

This is really big bug here.

I have to delete it and create a new one….

Reported almost 3 weeks ago. Still not resolved ? This is the one of the most commonly used basic functionality. Please look into it ASAP. Thanks 

I have the same issue - and it’s actually annoying because now it needs to create a new connection line every time. 

Same issue here! After I close the Miro board, the text on the connection lines are no longer editable!

Is there a fix for this?  I am finding it intermittent.  Some lines can have their text changed but others don't.  My workaround is to delete the line and add it with new text.  Not ideal.

This is happening for me. Came back to use Miro again after suffering from Gliffy sluggishness and clumsiness. Looks like its back to Visio for me.

Same thing with me, please, fix it!

Same issue

Also cam across this today and a bit of a pain to work around. Surprised this has been an issue for this long. @Miro any comment on this?



I’m facing this issue as well. It’s terrible that @miro has not resolved it yet.

I am facing the same issue, the way I solved is to create a brand new line.

Guys, get the desktop client! This bug does not exist there!

Thanks for sharing this, Albert! You saved the day!

same issue here, I noticed it months ago, tried again today, bug still there.

surprised Miro doesn’t engage with customers in this thread.

I am facing the same issue is there a fix for this. geometry dash unblocked

Ditto! Except I’m just starting to use Miro. I thought I was doing something wrong to edit text on a connector. Hehe...

Three months out and this is a persistent issue. It’s SO annoying to create text on a connection line and then be unable to edit it: the only way to deal with that is to create a new connection line that replaces it, create the text (the one time we’re able to) and then hope we don’t need to move it or edit it again.


It’s worth noting that this bug doesn’t affect ALL connection lines: just some… apparently randomly. I don’t quite understand what the difference is, which makes it more confusing. Ahhh… after some poking around: any connection line that already exists after loading a board (reloading the browser, navigating away and returning, arriving via bookmark) is un-editable. New connection lines created before navigating away are still editable.


This is extremely frustrating. Miro! I like your product but this is a relatively new issue (in the past few months) that continues to be unaddressed.


After reloading the program, the problem seems to have been resolved. Did my comment light a fire of pushed fixes??