Can't type in board?

New to Miro - Hello, I created a board but can’t type in it anymore - neither to edit stickies or text previously added by me, nor when I try and add new stickies - there just seems to be no option to change the text or type something new. this also happens when I create a new board - I can’t seem to type, nothing happens when I click in the space/on the sticky. I’m using Miro in Chrome, on my MacBook, and have just joined the lowest paid option (for three team members). Please help! TIA 

16 replies

Userlevel 7
Badge +6

@Melinda -

Are you able to try using the Mac desktop app to see if it is a browser-issue? When you go to the Miro dashboard does it show that you are the owner? What do the share settings show when you access them from the Miro dashboard “...” menu for the board?


Can’t write on the board, tried everything, type on my keybord goes straight to select an action. 

I give up 

Also using Miro on Chrome (Macbook pro). I have this same issue.

I am using Miro with Chrome onWindows 10.

Userlevel 7
Badge +12

@Melinda / @Marina / @Marie Me / @Kevin Yang - Have any of you reported this to Miro support?

→ How to Contact Miro Support

Hi everyone, many thanks @Kiron Bondale and @Robert Johnson  - my issue seems to have resolved itself, curiously. I literally changed nothing, just went from not being able to type on board to suddenly being able to. Indeed, I a working on a Mac in Chrome, as other users here experiencing same. I did not report it, but will when I find time. 

I am having this issue as well. I have tried using the desktop app as well (for Mac) and Miro is completely unusable for me as I cannot type anything and double clicking/selecting a sticky note and hitting enter seems to do nothing.

Userlevel 7
Badge +12

@Kiana - If you have not done so already, please report this to Miro support - please refer specifically to the second table row in the help center article below where it states ‘Atypical issues’ - there is a link to contact Miro support:

Userlevel 4
Badge +5

I’m facing this same issue right now… :/


I tried both the app as well as the browser. I can only now type into stickies.

I had the same issue, I have not verified it yet but it may (unable to type into a sticky note in a template) have happened when I minimized two Chrome browsers side-by-side. Refreshing the Miro page in the browser (press F5) seems to have resolved the issue.


I had the same issue - couldn’t type anything but resolved it by simply refreshing the browser (thanks @Bian Mutang Tagal !

Was there a fix for this?  I can’t add text to stickies or tables.  I’m selecting object and start typing, nothing happens.


@Mitch Webster mine fixed itself by simply using the “refresh current page” (cmd R on mac). Haven’t had the problem again. I think it’s just a glitch that occurs every now and then.


I had the same issue on Chrome using a Macbook, but it fixed itself by refreshing the browser, as mentioned above. Hope this helps.

I had also the same issue on Chrome using Windows 10.


Any solutions so far?


Thanks in advance.

UPDATE - Solved

I turned off the Google Translate extension from the web browser and it suddenly works!

Userlevel 7
Badge +6

@Bedirhan KELEZ -

Try clearing your browser history & cache and restarting the browser. You can also try using incognito mode…