Can not find timer in specific board although the timer already installed

  • 15 September 2022
  • 5 replies

Why I can’t find timer on some of my boards, even though I have installed the timer apps and also I’m not GUEST.

Timer has been installed
No timer access on the above tools
No timer access from the sidebar tools


5 replies

Userlevel 7
Badge +12

@mind88 - Try in here and then dragging it up with the rest of your apps:


@Robert Johnson I have tried but still can’t find timer 


@Robert Johnson in the board that I had the timer access, when I clicked the 3 dots button it shows like this 

Archived board


But in the new board it shows like this, even though the role is the same as editor


Userlevel 7
Badge +12

@mind88 - Hmmm. Something is off/different than what I have seen before. In your screenshot where you show only Duplicate, Open in new tab, and Copy board link, that isn’t even what I see as a Guest, e.g.:


However, in your screenshot while on the board itself, I am not seeing a Share button at the top right (or any button) - e.g., as the board owner and a team member I see:


But as Guest on the board I see:


But on your board we are seeing:


Have you tried:

  • clearing your browser cache
  • an incognito browser window
  • another browser
  • the Miro desktop app
Userlevel 7
Badge +12

Also, do you know what Miro subscription/plan type this board resides in? (Team/Starter, Consultant, Business, or Enterprise?)