Bug with text boxes: Unable to resize

  • 7 September 2023
  • 6 replies

Hi there Miro


There is a bug with text boxes.


I create a text box.  I delete the placeholder content.  I type the number 3.

The control handles for the text box cannot be reduced or collapsed and appear to be a fixed size.  I have tried deleting the board and starting a new one.


In the video, I am trying to collapse the text box so that it only shows the 3 with no whitespace to its right.   The text box does not allow me to collapse it at all.


I did install two randomiser apps; which I have removed - one generated text box die numbers -- perhaps this is the cause?


Regardless, whatever I do; it will not allow me to collapse the anchor points on a text box


Video (Imgur)



Any further assistance on this, would be great.




6 replies

Hello there

I was able to reproduce this bug this morning.

Cleared all cookies and cache, disabled all extensions.

I deleted the board, created a new board.

I created a text box and entered a single character, “3” or “T” and then I wasn’t able to collapse the text box, but I can make it wider and shorter, along the horizontal plane; but there is a point where I cannot collapse the text box and it has a large whitespace after the character entry.

I have reproduced this issue in Chrome Version 116.0.5845.142 and MS Edge Version 116.0.1938.76

Ok, its just that I don’t have any recollection of this issue happening before the date on which I posted it.  But if its expected behaviour I guess that’ll have to do.

I’ll use shapes for single characters.

Userlevel 7
Badge +12

@Amarjit - I am unable to reproduce what you are showing. I tried on Windows 10 and 11, from the Miro desktop app, Chrome, Firefox, and Edge.

What is your setup?

Have you tried from another browser/the desktop app?

If you are using a browser, have you tried disabling all browser extensions (an incognito window usually accomplished this).

Userlevel 7
Badge +12

@Amarjit - Thank you for the additional information. Can you please further explain (or include a screen recording) of what you mean by “collapsing” a Text object? In my mind, I see this as collapsing/expanding:


When you say this:

I wasn’t able to collapse the text box, but I can make it wider and shorter, along the horizontal plane


Text boxes can only be independently adjusted on their horizontal place. For example:


However, a Shape object can be adjusted:

  1. Horizontally
  2. Vertically
  3. Diagonally 

Using your context

“Text boxes can only be independently adjusted on their horizontal place.”

The text box anchors can be moved on the horizontal plane ← or → but the problem is that there is a point at which I cannot collapse (that is to say move the anchors ← (leftwards) beyond a certain point and it creates whitespace.

I’ve now included a video from imgur below



Video #1 (Imgur) - Tried on initial post some days ago



Video #2 - Tried 12 Sep



In both examples I can adjust the text boxes horizontal plane → but I cannot ← when it gets to a certain point.   It looks like it has whitespace to the right of the character “3” but there is none.

I am not sure what is causing this whitespace, nor how to collapse the text box along the horizontal plane ← (to the left) so that I have a text box with a single character with no whitespace trailing it.


I hope this clarifies my issue.



Userlevel 7
Badge +12

@Amarjit - Thanks again for the additional context and examples.

To be honest, I believe this is the expected behaviour of a Text object in that it cannot be make to be a single character wide. I am setting the same behaviour as you across all platforms and Miro clients that I use.

This Wireframe library Text object behaves the same way.

You could use the Shape object to make a narrow text-like field:


If you still believe this is a bug, and you have a paid subscription, you could report it to the Miro support team.

I’m sorry that I don’t have a better answer for you.