Anyone know how to remove miro app as the default application for a miro url? (Mac)

  • 9 October 2020
  • 11 replies


I changed my mind and don’t want to use the miro app anymore. I want to use it in the browser. I have wasted so much time trying to find out how I can change the default application for the url back to the browser not the app! anyone? I get this alert everytime I open a link.

I’ve tried

  • deleting miro app
  • resetting browser settings

Basically I don’t know how to access a miro url to say “always open in browser”


11 replies

Userlevel 7
Badge +5

Hi @bridget,

The team told me that you should (1) fully delete the app, (2) check that you don’t have the installation file in the Downloads. and (3) reset browser settings to their original defaults.

After that, the browser should not suggest or try to open the links in the app.

I understand that you’ve already tried these steps, but could you please check it again, and if the issue repeats, reach out to the Support team directly?


Thank you!

I am having the same problem in Firefox on Windows 10. It is completely unclear how to remove the miroapp association from the browser.


In Applications in about:preferences there is no way to remove an association from within the menu. The information is stored in handlers.json inside AppData\Roaming\Mozilla\Firefox\Profiles\{profile}, and I tried deleting handlers.json as well as handlers.json-corrupt (or whatever it was called) and restarting Firefox, and the Miroapp popup still comes up.

Userlevel 7
Badge +5

Hi @Daniel111111222222,

Just to confirm: have you changed the settings to Always ask in Firefox? 


If there’s no Miro app on your device, the browser won’t ask where to open the link.

I had the same issue in Chrome. I uninstalled the app, deleted any associated hidden files that were still on my computer (and emptied recycle bin), cleared my browser cache, and restarted my computer. Still, every time I clicked to open a Miro link I got the popup asking if I wanted to open it in the app. Something has gone really wrong here :/


The way I got it to stop was just telling it to ‘always’ open links in the app (which I don’t have anymore) - this stopped it asking, and also just defaulted to opening it in my browser because obviously it couldn’t open in the app. :shrug:

@Marina  I think the setting was “Always Ask” before I deleted handlers.json and handlers.json-corrupt. I’ve since deleted both files, and I still get the message asking to choose an application to open a miroapp link.

I’ve even tried making it use firefox.exe and setting it to always use that application, but it forgets that I’ve done that and keeps asking to choose an application.

When I try to make it always use firefox.exe in the Firefox options with the “Use other” menu, it doesn’t remember that either, only showing me this dropdown.

Userlevel 7
Badge +5


Oh, I see. For Windows, there’s one more step - to clean the registry manually.

Please reach out to the Support team - they’ll send a special file to you to do this.

@MarinaThank you for the tip. I was able to clean the registry using the builtin Registry Editor. Deleting the entire ‘miroapp’ item in the left window here and restarting the computer did the job. (Deleting the data in the right window for miroapp and all of its child items did not suffice.)


Hi, I've read this thread but whatever I try, I can't prevent the dialog being show below whenever I try to open a URL to one of my Miro-boards.

I had Miro app installed, but deleted it (and the DMG it came with) from my Macbook, and since than I always get above dialog when opening URL such as<board id>


I just solved this issue for myself. I am on a Mac and using Chrome.

Under Chrome settings > Privacy and security > Pop-ups and redirects

I blocked

and it seems to stop links opening in the desktop app. I hope this helps others!

I am having the same issue. Not a good user experience.


Had less difficulties deleting a Virus/Malware :sweat_smile:


Any solution to fix this without having to explicitly block anything in chrome?

Userlevel 1

Did you try this


I had the same problem and it worked for me.