Copying and Pasting not working on Board

  • 18 March 2021
  • 5 replies


Suddenly copying and pasting in Miro board is not working

I attempted to copy and paste through Key-board (Ctrl+C, Ctrl+V) and it worked nothing.
nothing happened.

so i tried to another way which i clicked right button of mouse and chose copy and paste from the menu, but the message said “These actions are unavailable via context menu. Please use : Ctrl +C, Ctrl+V)”


How can this problem be solved. Is there a setting which was by accident triggered which could have caused this?



5 replies

Userlevel 7
Badge +14


Can you provide more details - are you attempting to copy content within the board itself or from an external application into Miro? Are you accessing Miro through a web browser or via the desktop app?



I have a similar problem. 

Copying PowerPoint slide into Miro not working - it was yesterday.  Same thing using snipping tool to grad web content to copy to MIro.

Userlevel 7
Badge +16

@SOON & @sharon Jones - I just tried this and copy-and-pasting from PowerPoint and the Windows Snippet tool is working for me in both Chrome and the Miro Desktop App. Here are my details:

  • Windows 10 Home 64-bit version 2004 build 19041.867
  • Chrome Version 89.0.4389.114 (Official Build) (64-bit).
  • Miro Desktop App 0.5.2 (from, not the Microsoft Store version).
  • Desktop version of PowerPoint, M365 version 2103, build 13901.20336.
  • Unsure of the Snippet version.

What conditions are you unable to copy-and-paste from? (operating system/browser/PowerPoint version etc.)?


Same problem with Firefox 61.0 (32-Bit). With Chrome I have no issue

Userlevel 7
Badge +16

@Renato Raymann - 61.0 appears to be quite old - according to the following site 90.0.2 is the latest: