Shameless plug for my new Miro plugin CarbonCopy

Userlevel 4
Badge +3

Welcome to this promotional post for my plugin: Carbon Copy.

The plugin lets you update an idea in one place and sync the idea across widgets everywhere on a Miro board. Give it a try and let me know what you think, how you use it and whether it inspires new ideas. Just share your feedback, it’s all welcome.

This is a personal project, I’m doing it for fun. I will implement some improvements over a few months, if you come across bugs or problems I will fix them more quickly.

Just @mention me in your posts here on the forum, or reply to this message.

40 replies

Userlevel 1
Badge +1

Hey, is the tool somehow still available?

The website page says it cannot find it in the marketplace?



Userlevel 7
Badge +7

@Markus Smet Opening it so anyone can contribute sounds like a great idea. Open source ftw! 😀

@Markus Smet , thanks for the reply! 
I actually have the exact same problem when trying to use the Carbon Copy app in a browser (Chrome). But I understand that you are no longer developing it and we need to take the app as is 👍

Thanks again and I hope you have a great day :)

Userlevel 4
Badge +3

Thanks everyone for your comments and questions.

I’m not actively developing the app so it has to be taken as is. If you are not sure, I would suggest installing it on a trial and checking whether the features fit what you need.

Please bear in mind that you must run this plugin in the browser for it to work, this is because I have to store reference data outside Miro to maintain sync’s between board widgets (e.g. post-it notes). So if you use the Miro desktop app remember Carbon Copy won’t work.

I will consider whether it’s worthwhile updating CarbonCopy to the new API. If someone is interested in taking the product idea forward I can also consider opening it up so anyone can contribute.

Hello @Markus Smet , thank you for this great app! I have used it on my personal Miro boards and I really like its potential. I am trying to use it at work, but I am struggling. 

At first the app didn’t show at all in my work Miro because it wasn’t approved by my company’s security team. Now it is approved by the security team and I can now see it when I search for it. I authorized and installed it, and got the “App has been installed” banner, but I am not able to actually use it.

Have you heard of anyone having this sort of issue and know of a potential solution?

I uninstalled the app from Settings so that I could replicate what I did and take screenshots this time to show you. Below are the screenshots of what I did in sequence:

note: I highlighted the title of the dialog for some reason ‘:)
I get the “App has been installed” black banner
I tried to drag the App to the left toolbar but I was not able to do so.

So I tried again to install it:

now the button says “Reinstall”
I again get the “App has been installed” black banner
But I still cannot drag the app to the left tool bar and use it :(

Have you heard of anyone having this sort of issue and know of a potential solution?

Thank you in advance!

@Markus Smet -- so, similar to Jenny above, we have some users in our team who like and want to use CarbonCopy. However, our team is orders of magnitude larger than Jenny’s, and we have now entered into a ping-pong game of uninstall for team (user annoyed by repeated auth requests) <> re-install (user wanting CC).  So, what’s the horizon on getting the app installed for individual users you mention above? Otherwise, would refresh tokens be a possibility, (see

Userlevel 7
Badge +7

@Jenny Tarwater Have you checked Team Settings -> Apps & Integrations? Just select the app in the Apps & Integrations settings and then click Uninstall for team.

@Markus Smet -- Hi! Are you able to respond to this please?

HI! @Markus Smet ! I love the promise of this plug in, and look forward to future versions. It didn’t quite work for what I wanted yet. 


The issue is I can’t uninstall it. I can’t find where on the board I had some Carbon copy items, so can’t delete/remove the CC functionality. Now all 20 people at my company keep getting asked to install it… and they are not so happy. 

How can I remove it so no one is notified any more? i saw your post about user v team permissions, and it doesn’t look like that is ready yet. 


For now, I have another Miro account I can do testing on, I need this completely gone from my company board, please!!

Userlevel 7
Badge +7

@Markus Smet Just wanted to say I love Carbon Copy! Let us know if you have a Ko-fi or Patreon so we can buy you a coffee as a proper thank you for creating and maintaining this amazing app. :innocent::coffee:

@Markus Smet, thanks for sharing and really a great plugin! Just one question, do you think you could add the functionality of multiple boards? eg. Board 1 has post and board 2 to has the synched post it? 

Thanks again!


Danny van Kent


agree this would be a super useful feature. Use case is:

  • we work with multiple boards internally as we design features
  • towards clients we have 1 board per client where we discuss/centralize finished features
  • currently we CUT(not copy)/paste from the internal board to the external board (to avoid multiple versions), but sometimes we want to keep it internally as well as we continue to futher enhance it
Userlevel 4
Badge +3

Here you go.

@Markus Smet, could you please share a link to the privacy policy? Thank you in advance!

It’s not working for me! The CarbonCopy UI has the Sync button grayed out - even after selecting things on the Miro board, as you do in the youtube video.

I’m using Miro’s “New UI”, by the way.

Edit: Ah, I seem to have narrowed down what is causing the bug. It doesn’t work on the “Database” shape within More Shapes (the cylinder).



I am considering adding Carbon Copy to Miro. I was curious if anyone has used carbon copy alongside of Jira integration. Did any onc experience any issues such as duplicate records in Jira, etc? I am just looking to see what other’s experiences were like. Any information helps! Thanks. 

Userlevel 1

I’m not sure if this is the right place to ask this question, please direct me to another post if there’s a ‘wishlist’ specific to Carbon Copy.


I was wondering if it would be possible in Carbon Copy v3 to include sync of ‘groups’. Unfortunately I’m often combining multiple shapes and text together into groups and I would love to be able to sync those objects across my diagrams so they’ll dynamically update.

Userlevel 4
Badge +3

:clap::muscle: CARBONCOPY v2 IS ON THE MARKETPLACE  :clap::muscle: 

At last you can once again maintain your duplicate Miro widgets easily with the CarbonCopy plugin.

I will make a new announcement on the forums in the coming days, but for those following this thread here’s a direct link to install from Miro’s marketplace:

Userlevel 4
Badge +3

Hello Everyone,

CarbonCopy v2 is now code complete and we have a lovely new feature to share. I still have to submit this via Miro’s sign off process to get it into the marketplace, after which I will open a dedicated new thread to it.

Here’s a preview of the new feature, hope you like it :)

Userlevel 4
Badge +3

I’m getting snagged in what I am allowed to do within a Miro board and whilst the new app I’ve built resolves the performance issues I must change how it works again to fit into Miro guidelines.

This will take more time, I would estimate CC won’t be available until end of Sept once everything has been developed, compliance checked and released.

You can still get a functioning version from me via a direct link, just DM me.

Userlevel 4
Badge +3

We are testing v2 of CarbonCopy. It’s code complete and we will push to release this week.

CarbonCopy v2 

  • Solved the performance issues when manipulating widgets on a Miro board (we stopped rendering the icons necessary to use CarbonCopy in the widget’s context menu)
  • Plugin options displayed in the Bottom Panel instead of widget context menu
  • Added a feedback option for ideas or problems you encounter (updated our privacy policy too)

I will update progress here and link to the new version in the marketplace once released.

Hey @Robert Johnson and @Markus Smet! It’s helpful to at least be able to see who installed it- looks like someone else on out team did install it and that’s causing the pop-up for others on the team. It’s just odd because when the others do as the pop-up asks and “Authorize” CC, it fails. I’m trying to reach the person that installed to see if there’s anything they can do because the alternative seems to be uninstalling the plugin for the team at this point.
Thanks for your help!

Userlevel 4
Badge +3

Hi Jamie,

I’m the author of the plugin. Sorry that’s happened.

If you didn’t install the plugin, did someone in your team add CarbonCopy to your team? That could cause everyone in the team to have to authorise the app.

I am working on a new version of the app that will fix issues and enable your team to install it on a user level from the marketplace so not everyone gets CarbonCopy installed when only one user wants it. We are working as quickly as we can to resolve this.

@Scott have you got any idea why this is happening?

// cc @Ramkumar 

Userlevel 7
Badge +12

@jamieHP - I moved your question to this post.

A member of your Miro team has installed the Carbon Copy app on your team installed @Markus Smet‘s Carbon Copy app. However, the app appears to be experiencing issues at the moment.

Depending on your Miro plan type/set up/role, you may be able to uninstall this yourself or at least see who installed it and reach out to them.

You can try:

  1. Clicking on the Team profile settings button:
  2. Clicking on Apps & Integrations:


  3. Once you select the app, you may see who installed it:

If you don’t see the same screens as my screenshots, I would suggest reaching out to some of your Miro team members to ask who installed it.

Today I started getting a popup on my boards to “Please authorize Carbon Copy.” When I click “Authorize” then I get an error: “We couldn’t install this app. A client must have at least one registered redirect URL.”

I’m not doing anything fancy with my board, and am not syncing data between boards or anything like that. I have never knowingly installed or used Carbon Copy and am not sure what to do. Anyone else having this issue or know anything about it? 

Userlevel 4
Badge +3

Hi Adin and other followers of this thread,

The issue is broader than expected so may take longer to fix. CarbonCopy uses the ‘onSelect’ event to run code and render the icons used to ‘sync’ a widget (like a Note, Shape or Line) into the context Extension Point.

  • Icons rendered as iframes: I’ve found that miro is trying to render the sync icon used in CarbonCopy 'on select' of any widget as an iframe, an iframe is technically a new sandboxed html page. The iframe page is not lightweight element so it produces an overhead in render and display of the miro widget.
  • No data changed event: In addition, there isn't a data changed event which would also help make the app more performant. The metadata change fires only when we update the metadata not the widget's text data, so it can't replace 'on selection' change event used in CarbonCopy. Data broadcast is also something we need to trigger manually not something which fires on data changes.

Am working on this with @Scott  from Miro to see what can be done, if necessary I will re-design the app to resolve the icon rendering issue, this could help quite a bit. However that will take time (about 1 month).

If you or anyone else wants access to the app whilst it’s off the marketplace, send me a private message and I can give you a link to install it directly.

// cc @Ramkumar