Images break when exporting to PDF


Hi,

I’ve been trying to export my artboard as a PDF and all the images I had in the artboard are showing up as broken links. See the image attached for reference. On Miro (web version) the images are fine, but this happens only when I’m exporting to PDF, its fine when I export to jpg but the resolution is not what I want. I am using a pro account so this shouldn’t be happening. PLEASE HELP!  

 

 


21 replies

Userlevel 7

@Vishaka -

there was a similar thread yesterday from another user who was having difficulties with the export capability from the native Windows app. 

Are you doing the export from that or through the web app?

Kiron

I was using it on web and also on iOS app. When trying to export from the iOS native app I just got an unending loading graphic. The image above is from when I exported from the web app.

I did manage to solve it though. I grouped the contents of the artboard and the resized it a bit, followed by undoing my resizing and ungrouping the contents. Then when I exported it worked. Dunno if my resizing re-linked the images, but this seems like a bug in Miro.

Userlevel 7

@Vishaka - might be worth letting support know about this if you are able to reproduce the bug...

Userlevel 2

I have the same issue, both the images that I have uploaded (drag and drop) from my computer + icons that I have added through the icon finder show up as unlinked in pdf exports. I have a consultant account so I use the high res type of pdf export. 

 

I tried to ungroup, resize, regroup, rename the file name both in miro web app but also the original file on my computer - the error still persists. 

Real irritating issue since I need to export the board as a delivery to my customer, but can’t do that with missing images like this. Please help

 

Userlevel 7

I’ve tried to reproduce this through the web browser and was able to with a best quality PDF export. It works fine with a small file size PDF.

Small File Size:

Best Quality:

This is a pretty major issue as exporting to PDF is a very common need. 

I have opened a high priority support case and I hope @Marina can help to get it escalated as this is a very commonly used feature when sharing the outcomes of workshops with clients.

Kiron

We are having this issue as well, and we’ve got a client presentation (in Miro) this afternoon after which we need to provide a PDF copy of the outputs. Not sure what to do.

Userlevel 7

Hi all,

@Kiron Bondale, thanks for mentioning me, and thank you for raising the support ticket. I’ve asked the team to pay attention to the issue.

@Johan and @Peter, if you still experience this issue, you can also submit a support ticket at support@miro.com so that the agents update you when the issue is resolved. 

I have just updated my Miro board so that all the frames are the same size (A4), and the high quality export worked - all the pictures came out perfectly. I wonder if the issue has something to do with working with different frame sizes?

Userlevel 7

Hi @Peter ,

I guess not.

Many of my boards got different frame sizes.

Yesterday the output of them high and low quality worked perfectly.

Maybe the issue now is totally fixed.

Michael

Userlevel 2

This is an occasional bug, not a consistent one, so maybe it has something to do with the current workload request to Miro’s servers? I just tried a new export now and now it worked. In order to check this bug, I guess you guys need to check in your logs and see if there are any occasional errors when too big files are being asked to be exported - something like that - I don’t know, just guy-guessing...

I have experienced this bug at two previous occasions, so I don’t think we can count on this actually being solved until we get a confirmation back from Miro tech team. 

I’ve sent an email with a link to this thread to support@miro.com, thank you for that suggestion @Marina 

Userlevel 7

Folks -

I received a response to my support request this morning that the bug had been fixed - I checked and it seems to work fine, both for a board-level high quality PDF export and a frame-level PDF export. 

Thanks Miro Support!

Kiron

Well, I do have the same issue still. Does not work at my end : (

Userlevel 7

@Sebastian Lofvall -

Can you provide some details of how you are accessing Miro and what plan you are on? I am on the Consultant plan and just did the export successfully on a Windows PC using Google Chrome…

Kiron

Userlevel 7

Hi @Sebastian Lofvall ,

I only can say that i just finished a meeting with successfully exported PDF in High Quality.

Last week same thing hasn’t worked - today and last week I used a Windows PC and Google Chrome, just as Kiron did.

If this doesn’t work for you please could you contact support@miro.com or better 

Open a ticket directly in your miro board and choose one of the sections.

 

Michael

 

Hi @Kiron Bondale and @mlanders 
I'm on the "Consultant plan". The problem has arisen quite recently. I have several boards I want to export as PDF. Two weeks ago it worked great. But now that I have updated some text in these, I can't get pictures (jpg, png) that are in my boards.
I have tried to update the pictures. Reconnect them., Put everything in new borads. Restart the app. export from the web. But nothing seems to work.

I have mentioned this for support but have no answer yet. But am really more interested in a time estimate for when I can make it work.

Using macOS Catalina, 10.15.4. MacBook Pro 16 "
Desktop application: Miro
Browser: Safari

Userlevel 7

@Sebastian Lofvall -

Unfortunately, I don’t have a Mac so can’t reproduce the issue. Have you tried to do it from your Safari browser instead of the desktop app?

Does it work when you select the lower resolution export to PDF?

Kiron

@Kiron Bondale 

Yes, I’ve tried the browser as well but no difference, unfortunately. 

/seb

Userlevel 7

@Sebastian Lofvall -

how about the low resolution export - is that working or not?

Kiron

@Kiron Bondale 

Well, right now both variants work, low and high quality. Brilliant! 🤩

/seb

Userlevel 7

Thanks for the follow up @Sebastian Lofvall! Hopefully it keeps working as I’ve a few workshops coming up where I’ll be heavily using that capability :wink: !

Userlevel 7

Hi @Sebastian Lofvall ,

how does it work today?

Yesterday I used it several times in high quality and it worked perfectly.

Michael

Reply