Miro Laggy and Slow

  • 4 October 2022
  • 6 replies
  • 86 views

I am opening Miro in chrome, i havent had issues till now, none of my miros load or spend too much time loading and cant work either because its laggy. someone has solved this ?


6 replies

Userlevel 7
Badge +6

@Diana Fuentes Rivera -

Can you check your Chrome version and see if it matches the one referenced in this Help Center article: https://help.miro.com/hc/en-us/articles/7877662322450

Kiron

this is my chrome version 

Chrome is up to date

Version 106.0.5249.91 (Official Build) (64-bit)

found out that in incognito is a bit “better”, how ever still is laggy

Userlevel 7
Badge +6

@Diana Fuentes Rivera -

Since it is a bit better in incognito mode, it might be that you’ve got an extension or add-in which is slowing things down. You might want to try selectively disabling those until you find the culprit. 

Is it happening with all boards or just one?

Kiron

Just one board, the other one has even more items and is not laggy, I re-used items from one board into this one, could that be an issue ?

Userlevel 7
Badge +6

@Diana Fuentes Rivera -

It shouldn’t but it does sound like there might be a few objects which are “large” and require more time to render than normal. The only way to isolate these would be to take a backup of the board and then start to delete objects selectively till you notice performance improving - I’d focus on images and uploaded content specifically…

Kiron

Not sure if is the problem but after a while of trying to optimize my Miro, discovered that when entering this elements, Miro starts lagging. 

 

 

Reply