Copy asset from one board to another

  • 28 April 2020
  • 16 replies

Userlevel 1

I have two Miro Boards. I want to copy some assets (a bunch of shapes, lines, text that form a large complex structure) from one board to the other. But the copy paste isn’t working?



Best answer by Chris Forster 28 April 2020, 15:09

View original

16 replies

Userlevel 1

Hi Chris,

You can do this. It depends on the navigation mode you are using. I have found that the navigation mode can differ between browser type too. I have tried this in Chrome, IE10 and Edge and they all work.

Go to the top right of the board and select the settings icon next to the Share button. In there go to the Navigation Mode. Change it to Trackpad or Touchscreen. I use a mouse, but have found when Mouse is selected as the navigation mode you can’t select and copy an object. 

Once you have change it you should be able to either Ctrl + C or go to the three small dot on the shape menu and you will find the copy option there.




Userlevel 1

Hi Paul - thanks for the quick response. Sadly, this does not seem to work. I had no problem selecting the assets, or clicking copy. But when I go to the second board and click paste, I get the previous item that was on the clipboard - not the new assets I tried to copy. Any other suggestions?


Userlevel 1

Hi Chris,

I’ve just tried again by creating a bunch of line, boxes, connectors and a jpeg and when I select the lot Ctrl + C then go to the other board and Ctrl + V it works every time. I was in Chrome. 

I did get this message when I tried to right click and paste



Userlevel 1

Paul - thought I’d let you know I figured it out. It was in fact #usererror. I was copying between two different Miro accounts and this is a no-no, it seems. Once I shared the board between accounts I could do it. Thanks for your help anyway!


Userlevel 1

Otherwise referred to in IT helpdesks as a PICNIC problem...

Problem In Chair Not In Computer

Userlevel 7
Badge +6

The other option if you are not on a free account would be to back up the board to an RTB file and then restore it. That would work for a full board but not for a subset of the board.

Userlevel 4

I just encountered this problem. I build some content on a shared board for the board owner. I wanted to copy my work onto my own board for future use.  NOPE.  But I can copy from my board onto someone else’s. 

Two ways forward: 

1. Right now, ask the other board owner to copy from their board onto my own board.  
2. In the future, create work on your own Miro board and then copy and paste into someone else’s.

Userlevel 7
Badge +12

If you ever get this message:


Then the Board Content Settings need to be adjust to allow for content copying.

More on this here:

Userlevel 1

Otherwise referred to in IT helpdesks as a PICNIC problem...

Problem In Chair Not In Computer

I knew about PEBCAK (Problem Exists Between Chair And Keyboard)…

weird for me, I am having different boards under same account. trying to copy (command +c) from one board to another (command+v). It isn’t allowing me to do these actions. Once I restart the system it just allows me to perform these action only once and after that no response. 

when I do the action every time (command +c) the edit menu on top blinks and same for (command+v). although I can perform these actions outside MIRO. the problem seems to be with MIRO only.

Please help me solve this problem.

I was just having this problem as well. A system reboot seems to have solved the issue for now but seems like copy and paste should be pretty simple. Has anyone at Miro discovered the cause of this issue?

I discovered, if we use MIRO on browser, this problem persists.

The solution to this is to download MIRO app. I have done it and since then no problem at all.

I got a similar weird problem of not being able to copy content from one board to another even having permissions…
I found a similar approach to what @Aaron Stites  suggests.
If you close the board where you want to copy your content and open that again then it successfully gets whatever is on the clipboard. But it seems it stays in a kind of web-cache and does not reload it, so for every new content you want to export from one board to another you have to reload the window/tab to be able to do so.
(By the way that was in web-browser, not app)


I have a similar problem. Can’t even copy within a board or between them. I am the board owner of both boards! What I have copied shows itself for a while and then goes away. What is going on??? 936 objects I am trying to copy...

Worked after restarting the website! 

One solution to this is to create a pesonal template of the complex structure. Highlight all the elements you want to copy, right click and add frame...or if available, directly ‘save as template’. Save this as personal or as available within your team. Then open your new board and go to templates, and scroll down to personal and you should see your complex structure there as an option.