Copy and paste is not working

  • 26 January 2022
  • 29 replies


Unfortunately for me copy and paste and trying to duplicate one of my boards isn’t working for me. I’ve tried on the Desktop app and Google Chrome - neither work. I have cleared cookies etc. still not working for me. Any suggestions?

Robert Johnson 1 year ago

@John Das - If the board this is happening in is labelled as “PESONAL”, these boards are a beta feature. Miro is aware of the the copy-paste issue in these boards and will fix them in a later release.

More on this here:

For context, here is what a personal board looks like from a Miro dashboard:


View original

29 replies

I have the same problem in firefox nowadays, it’s copying and paste some old content, sometimes latest, but mainly old … but i remember it was ok some months ago… I use Ctrl-C/Ctrl-V

Same issue here on Firefox116.0b6 and Mac.

Same issue in Firefox 115.02, Windows11.  There are lots of CORS errors and some javascript errors in the console.  Seems to be an issues with the site.

This seemed to work before when I first created the board a few months ago.

I have exactly same problems that were described above. 

It is hit and miss. One day, I can copy and paste another day I can’t even though I am doing same operation on the same board from same PC.

 It seems that many users experience same issue for a while. I wish it is resolved ASAP.