[RESOLVED] Can't move/delete kanban card

For some reason I can’t delete these boxes that say type something:


If i select delete, they disappear then reappear again immediately. Anyone have any ideas?



36 replies

Userlevel 4

Hi @Ben Chase,

Clicking on the plus sign/the area below the current card will create an additional/new card.

After you delete a card, are you accidentally clicking that area to create a new one?

Michael Sohn


I m have the same issue, I recorder what’s happening, does anyone have some clue?


Userlevel 7
Badge +6

@Kenshin -

Wow - the box that won’t die! What browser are you using - if it is IE, have you tried in Chrome since IE does have some challenges with Miro? Have you tried deleting the cards using the Miro desktop app?


@Kiron Bondale 
It is quite a funny sensation. I m using Chrome. Not sure what helped, clearing cookies with ctrl+f5 didn't for sure, but the next day I’ve tried deleting it and had no issue with it.

I am not sure if I can give any advice to people in the future who have encountered this problem.
A bit random, not tragic, more of a funny one.


I have the same problem but nothing will make the box go away. I am using the miro app on my mac. Does anyone have a solution? I’ve had this before where waiting for the next day unfortunately doesn’t solve the problem for me. 

It also will no let me delete the template the box is in either.

Userlevel 7
Badge +6

I’ve also had this happen during a recent workshop where a card refused to move from one column in the Kanban board to another. A day later, no problem.

I’ll chalk it up to solar flares :joy:


I am having the same problem on 86.0.4240.111 .  Waiting a day is not a great solution since we are testing MIRO for client presentations!

Userlevel 7
Badge +6

@George Davis -

are you able to access the board using an alternate client to see if that enables you to clean up the unwanted cards - e.g. if you normally use a web browser, try the desktop app?


I was able to delete it an hour later in the same prezo, so I can’t reproduce to try a different browser.  However, it’s odd to see this marked solved since it is clearly impacting enough people to attract several replications that report here.

I’m having the same issue. I duplicated an item in my kanban list, edited it, but the changes wouldn’t take (it always reverted to the original duplicate). Tried to delete it and it just re-appears. Using the Chromium version of Edge.

I too am unsure why this topic was marked resolved- when a fix hasn’t been provided! Where are the moderators/ devs of miro on this?

It is really impacting my workflow not being able to move cards on Kanban from “in process” to “resolved” , or deleting redundant ones.

Anyway, just thought I’d better add my name to the list of people who want this fixed… maybe one day.

Userlevel 7
Badge +6

@Marina -

Given the inconsistent behavior associated with this issue (i.e. it does not happen all the time on all Kanban boards but once a particular board is affected, it is affected for all users at that time), can you check internally to see if there’s awareness of the issue and whether it is being investigated?



Userlevel 7
Badge +5

Thank you for the mention, @Kiron Bondale!

Absolutely. I’ll check in with the team and get back to you. 

I’ve seen the same issue a few times and came here to see if there was a solution posted. It does always resolve itself eventually, but till then I create a copy of the Kanban which is usually glitch free and move the original stubborn one off to the side till it will let me delete it. 

I have been having the same issue with Kanban template for the last week or so.

I have tried it in Chrome and Microsoft Edge.

Cards get stuck and won’t move or won’t delete. 

I’ve created a Kanban 3 times and each time this problem occurs. 

It’s really frustrating and really frustrating that there’s no solution 5 months after it was reported.

Jan 3, 2021 and I am experiencing this exact issue. I am on Chrome Version 87.0.4280.88 (Official Build) (64-bit)

Hi - I’m having this same problem. I use Chrome as default but have tried in IE with same problem. Have tried creating a new column and moving all cards across and then deleting either the swimlane or column that contain the problem cards but it won’t let me delete that either.

Can see from the thread that maybe coming back to this later / tomorrow might help but obviously this seems to be a recurring issue and without it being resolved properly will cause a problem for day-to-day Kanban management.

I have the same issue.. Running Safari on Osx. only happening on the most right hand column.

Also, anything I add is then un-renamable.

wow, now after I duplicate the Kanban board, I can delete the offending column, but now I can’t delete the original KanBan board.

Userlevel 7
Badge +5

Hi everyone,

I’m sorry you all experience this unpleasant issue!

Our engineers are trying to reproduce and fix this issue and need your help - could you please reach out to the Support team (with the reference to this thread) and share the affected boards with them? It will help the team to investigate the case.

Thank you!

Userlevel 7
Badge +5

I’m experiencing the broken / zombied kanban now as well. reported it to Support. 

Userlevel 7
Badge +12

While the ability to delete the card does seem to eventually return, in the past I have been able to force it by

  1. creating a new card in another column
  2. and then dragging the newly created card above the stuck/undeletable card.

Once I have done the above, I have been able to delete/move the problem card. Again, it has been hard for me to document exactly what has worked as the problem is sporadic and I usually solve it out of a frustrated barrage of actions.

Userlevel 1

I’ve just run into the same issue during a team meeting. No one out of 11 people were able to move cards from one column to the next in a Kanban. The other Kanban in the board are not an issue. Usually it works again the next day..

This would be an issue if it happened during a workshop. 

I feel like those unexplained issues are popping up more often, things like this or elements disappearing for specific users or not seeing text corrections. Refreshing usually doesn’t help either. 

We have the problem in Miro from time to time that cards in a KANBAN board cannot be moved or deleted. After a while it works again, but in a workshop this is very annoying. The problem occurs with different people, so also different operating systems / browsers - even in the desktop client. So it really looks like a board problem. The problem occurs in different boards.

Userlevel 7
Badge +6

@Detlef Hoefer -

It’s a known issue, but unfortunately it can’t be easily reproduced hence the Miro team have had difficulties in tackling it.