Miro won't load in chrome

  • 26 November 2022
  • 25 replies

It works in Firefox, or desktop app, but it doesn’t work in Chrome, even after clearing cache. I’m using the latest version of Chrome and Windows 11. I prefer using web than desktop app, and would appreciate any help you can provide. Thanks!



25 replies

Userlevel 3

Hey @albertng 
Could you please try the Incognito mode?

If in the Incognito mode everything works fine, please make sure to clear your browser's cache and cookies and then sign out and back into your Miro profile anew before checking the process in the standard mode. Additionally, please disable all extensions for your Chrome browser.

Please share your results with us!

Hello Helga,
I am having the same issue repeatedly.

It won’t open in Google Chrome unless I’m incognito. Miro opens in other browsers and for my coworkers without issues.
When removing cookies and website data related to Miro, I can access the login page and can select Google login. As soon as I perform the actual login, it shows the Miro loading screen and nothing happens.

Extensions are disabled.

I deinstalled Chrome once and it worked again for a couple of days, but now I run into the issue again.

Userlevel 7
Badge +6

@lsw -

Is the issue happening with just one board or with all boards?


@Kiron Bondale 
any board, https://miro.com/app/dashboard/, even miro.com, redirecting me to miro.com/app. I basically cannot access anything from Miro.

Userlevel 7
Badge +6

@lsw -

I’d suggest contacting support in that case - you can open a request here: Submit a request – Miro Support & Help Center


I also encountered the same problem. I'm curious how to solve it.

Same, but not even Incognito saves me. I need to use a different browser to access Miro boards (Safari, in this case).

I also have the same issue. Some coworkers too. We can use Miro in the app or with Firefox. 

But it only works with incognito mode on Chrome. Cleaned cashed didn't change anything.

Any traction on this? I am having the same issue. I have deleted cookies, cache, history, even reinstalled Chrome.

Hello, do you have a solution for this? I tried Chrome, Safari, Firefox, and only the loading icon appears.


I had the same issue in Chrome, the errors in the console are:

It works in Safari and incognito mode for Chrome, so I assumed it was something relating to the plugins (since they are disabled in incognito). Via a process of elimination I determined in my case it was the Testing Playground plugin: https://chrome.google.com/webstore/detail/testing-playground/hejbmebodbijjdhflfknehhcgaklhano?hl=en because disabling that plugin makes Miro work again.

I imagine it’s not the only plugin that has Miro has issues with, but it’s definitely a good starting point.

Hey there! Just wanted to let you know that I removed the TikTok Pixel Helper extension and now it's working again.


Hey there! Just wanted to let you know that I removed the TikTok Pixel Helper extension and now it's working again.

Thank you! 
TikTok Pixel Helper Extension was the issue 

Removing the TikTok Pixel Helper worked for me too!

Deactivating the Testing Playground did work for me as well, thank you very much, Adam.

In my case, incognito mode is not changing anything. I have to use another browser than chrome or use the desktop app to make it work. 

Removing tiktok pixel helper worked for me, too! Thanks for the suggestions.

@Helga, This is definitely a bug with Miro, do you know if it has been reported as such? If so any update on when this will be resolved? 

I had the same issue for months. So I could only use Miro in MS Edge. I got so tired of not being able to use Miro in Chrome. After deleting all the chrome extensions that I don’t use often, Miro started working again. 

I also have this problem. It is very frustrating. I do not want to disable the plugins I am using, they are all essential!!

Userlevel 3


Just to add Miro is working fine for me on Chrome, without disabling any plugin (unless there is any know issue with a specific plugin which i don’t have)

This is my Chrome version. 



For anyone coming here - it is most definitely a conflicting extension. Mine was Tron Wallet.

I have the same problem, even if I disable the few extensions I use. 

It worked last week, but this week it doesn’t work at all in Chrome. Safari is fine.

Version 114.0.5735.198 (Official Build) (arm64)

Hi, same problem here can’t load Miro on Chrome (Version 114.0.5735.198 (Build officiel) (x86_64)) since this morning, I did nothing special, tried everything listed here https://help.miro.com/hc/en-us/articles/360013588560-Board-performance-and-loading-issues and disabling extensions did nothing. Works on Safari.

I’ve tried everything above, in the end I’ve used VPN that saved me.