Miro embed (sign in) fails in Notion App - only connects in browser


Userlevel 1

I have tried every way I can think of to sign into my Miro account from Notion App to work on my Miro items within Notion. But I have failed! Is it actually possible (because it certainly looks like it…) to have a two-way sync with Miro in Notion?
 

In the browser, I have be able to get full editing rights, but in the Notion App I can only view… and that’s exactly where I want to work.. in Notion… I have read from older posts that only viewing is possible, but if it’s possible to work in the browser… surely it’s possible to work in the app??

 

The actual issue I’m facing is that the sign-in keeps failing…  After I click the “sign in” button in Miro in Notion, it takes me to the browswer to login… but once I complete the sign-in info it just dies… “Redirecting” for ever… so this is where it’s failing…

I do have at least 3 profiles I use in Google which may have caused sign-on confusion, but I’ve tried signing out of all profiles, and just using the one I want to use Miro with… I also have a different  sign in with notion account (through my college) so I even created a Miro account with that email to see if that works… still failing at the connection point… although why is Miro asking me to sign in if the connection Is only for public viewing - which I have tested and it obviously works (because no sign-in is required).

 

Please advise if I am thinking about this wrongly… thanks!


28 replies

Same issue

Same problem here. 
MacOS / Windows 10, Notion App and online: does not show board. 
Guest Links should at leat be visible, by definition they do not need a login at all. 

I’m having the same problem.

I have this same problem.

Same issue in windows using the Notion native app and the miro website.

Same issue here

Macbook Pro 14” 2023 model

Same here.

What’s going on with this bug? Is on the side of Miro or Notion?

@Miro team, any updates on your side?

Same here

Is this matter being abandoned?

Same here:

  • Macbook pro M1
  • macOS 13.5
  • Notion 2.2.1
  • Browser: Sidekick 114.50.2.35130

Same problem here. 

Still a problem on Windows 11 (64 bit) Version 2.2.1 a year and a half later. This is stopping us from using the desktop app.

 

 

Hello, I have the same problem. +1 since it seems you guys do not pay much attention to this bug

Hey, would you mind replying to your users and try to fix this. This bug is quite disturbing and shouldn’t be too hard to fix since other apps integrations are working well. But even if you can’t fix this now, answer to your users when they’re reporting bugs for you.

Still not fixed. WHY?

 

Has this not been fixed already??

Looks like an issue from more than a year ago.

 

Please allow this 🙏

Same problem here. It works well in the browser, but not in the notion app. Always shows the sign in sign up buttons.

Having the same issue in Version 2.1.15 (2.1.15) on the Mac. Works fine with the Windows users I have. Just broken for all the Macs. 

Problem still present on v2.1.14 on Mac

Userlevel 1

I have a similar problem. Logging into Miro from an embedded view in the Notion app brings up a fresh login screen in my browser (even when I am already logged in within my browser). Logging in doesn’t seem to change anything in the Notion app. The Miro embed in Notion hangs on the message: “Authorization in a new tab”. If I open Notion in a browser everything works fine. This seems to be a Miro authentication issue specific to the Notion app.

Same problem here.

What is the status of this issue? We are experiencing the same issue. Would love to leverage directly from Notion app.

I have this same problem. It’s been 10 months since the thread was opened. Is there an update on this? It’s super annoying to only be able to use miro embeds through notion in the browser.

I have a same problem, and I submitted the issue.

Userlevel 3
Badge

@Sebastian Wilgosz Thank you🙂

@Helga I submitted the request, with a video and device/soft details included. Cheers!

Reply