I want to wheel zoom in smaller steps, how?

  • 3 February 2021
  • 21 replies
  • 2649 views

Userlevel 2

Now when I zoom into project (when editing) by using mouse wheel I get jump between 51% and 143%, this makes it unusable. I need to zoom with more steps in between the 51 and 143 percent. How to configure these steps of zoom?


21 replies

Userlevel 7
Badge +6

@Aladeen -

Interesting question - I set my Windows mouse settings to only move 1 step at a time with the trackwheel and I found that with different Miro boards I was getting different zoom increments ranging from 3-8%. 

My guess is the zoom increments are controlled by the setup of the board itself - perhaps the overall size or dimensions.

@Marina - any chance you could dig up any info on this?

Kiron

Userlevel 7
Badge +5

Great question! I’ll ask the team and get back to you.

Userlevel 2

Thanks for the response. I might add that I am using Firefox on Ubuntu. It may not suit someone, but it serves me well. When I scroll webpage (eg this thread) I get small steps, the scroll jumps one or two lines at a time.

Userlevel 7
Badge +12

My zoom increment experience is different between Chrome and Firefox (it takes more wheeling to zoom in Firefox).

Userlevel 2

My zoom increment experience is different between Chrome and Firefox (it takes more wheeling to zoom in Firefox).


Hmm, I wonder what is the difference between your settings and mine? I don’t know how much system settings affect behaviour of Firefox. Maybe there is something in Firefox’s “about:config” I could change to make it better.

Userlevel 7
Badge +5

Hi there,

So the team told me that this is not board-specific and Miro shouldn’t influence it at all.

We also checked this behavior on Ubuntu and it’s okay - 10-11%/mousewheel step.

I also have a problem with this.

Scrolling the mouse wheel in Chrome takes me from 6% → 26% → 117% - three increments that are too large to be useful and make navigating the board difficult.


I’m using Windows 10, the latest version of Chrome, and I don’t have any special accessibility settings I’m aware of that might influence the scroll wheel behaviour.  Zooming on other web apps works as expected.

 

Zooming on Miro in Firefox also works as expected (increments of ~1%), but I need to use Chrome for my other work so it’s quite inconvenient to have to use a different browser just for Miro.

 

Thanks for your help!

On windows 10 chrome 89, I zoom out from 100% > 33% with one tick and zoom in from 100%  > 272% > 400%.

This basically makes mouse wheel zooming unusable. 

Other similar products (sketchboard, lucid spark,...) do not have this behaviour at all. 

 

There’s a related request on the miro wish list here : https://community.miro.com/wish-list-32/custom-zoom-percentage-1016 

The problem is caused by a bug in Firefox v88 - see all details here: https://community.miro.com/ask-the-community-45/known-bug-zoom-on-firefox-v88-doubles-every-time-you-zoom-in-out-4631

Userlevel 1

I ran into this problem as well on Linux, Chromium based Vivaldi browser. Zoom with the scrollwheel jumps between like 50% and 150%, completely unusable.

I have the problem on Ubuntu 22.04 with Chrome - zoom goes from 38% to 125%. My default browser is Firefox but Miro is unusable there. Way too many issues to list. In Chrome is works well this is the only problem I have.

Same issue on same platform, voted up OP

For now I use this workaround: press Ctrl++ and Ctrl+- ...

I have the problem on Ubuntu 22.04 with Chrome - zoom goes from 38% to 125%. My default browser is Firefox but Miro is unusable there. Way too many issues to list. In Chrome is works well this is the only problem I have.

Check your computer's system settings or control panel for mouse or touchpad settings. Look for options related to scrolling or zooming, as there might be settings to adjust the scroll wheel behavior or zoom sensitivity. Some applications, particularly image viewers or design software, may have specific settings for zooming behavior. Look for preferences or options within the application itself to fine-tune the zooming increments or sensitivity. Hold down certain keys while scrolling to achieve smaller zoom steps. For example, on some applications or devices, holding down the Ctrl or Shift key while scrolling the mouse wheel may result in finer zoom adjustments.

I had this problem and the workaround I found is to first drag by holding right click, and after dragging, zoom starts working better (don’t hold Ctrl while zooming, just the wheel).

PD: using Ubuntu 22.04 and Google Chrome Version 114.0.5735.133 (Official Build) (64-bit)

I’m using the Miro app on MacOS 13.4, and experience the same issue generally described above (Zoom levels going from 400% → 250% → 36% → 24%) on when using CMD + mouse scroll wheel (Logitec G900).

@Pablo Cettour‘s comment of the right click drag, then using the CMD + mouse scroll combination does work / ‘fix’ the issue (now 400% → 294 → 216% → 159 → 117 → 86 → 63 → 46% etc), which is much more usable. 

Definitely a bug though.

Using Chrome Version 114.0.5735.198 on a ~2yr old Macbook Pro and a Logitech MX Master 3 mouse.  When I zoom with the mouse wheel it jumps between 25% and 276%.  Is there some fix or workaround for this? Does Miro at least acknowledge that this problem exists?

 

Using Chrome Version 114.0.5735.198 on a ~2yr old Macbook Pro and a Logitech MX Master 3 mouse.  When I zoom with the mouse wheel it jumps between 25% and 276%.  Is there some fix or workaround for this? Does Miro at least acknowledge that this problem exists?

 

Hi Reed,

 

Thanks so much for bringing this to our attention.

 

I also experienced the same issue as you with a similar set up. However, I was able to fix behaviour by installing the Logitech Options software (for macOS) which includes driver bug fixes for the Logitech MX Master mouse.

 

Please let me know if this also solves your issue.

That appears to have fixed it - thank you very much, Ben!

Same here, Chrome on MacOS14

zoom steps: 7% - 36% - 400%

 

I also bought a graphic tablet wih a dial and that has a different behavior, but still not useful.
Inconsistent zoom in and out
in: 20% - 33% - 50% - 75% - 100%...still too large and snappy steps.
out: always to 16%

Is sometimes uses more reasonable steps, and I haven’t figured out what triggers that yet.
It happens when holding shift and scrolling, but normally that combination is for pan, not zoom. It triggers for no apparent reason.

Now, forget about the dial on the tablet, let’s consider just the mouse wheel: what should I consider?
Is it too much asking for a dimmer to embeed in miro so that no matter which system we’re using we can finetune it from the webapp settings?
Just 2 sliders (one for zoom in and one for zoom out, please keep them separated) which multiply the zooming factor at will.
 

I still have the similar behaviour with Chrome when zooming with the mouse wheel 

2% - 7% - 24% - 80% - 264%  

Kubuntu 23.10, Logitech MX Anywhere 2S mouse, Chrome Version 120.0.6099.216

When I use Firefox, zooming works great, with small steps 

 

I’ve had the same issue on Firefox, where it would zoom from 16->50->165%.

This is the workaround:

  1. Go to `about:config`
  2. Find the `mousewheel.with_control.delta_multiplier_x/y/z` properties, and set it to some lower value. For me, 30 works about right.

Reply