CORS error on realtimeboard API

  • 18 November 2020
  • 9 replies

Please excuse my ignorance but I wasn’t sure whether to send this directly to support or post it here, and thought it would be good to get this visible if others are having the same issues.

Images on Miro boards aren’t loading for me and it seems related to a CORS error with the realtimeboard API. Images start to load (blue inside the circle) but then they error.


Miro Board


API Response


9 replies

Userlevel 4

Hello Philip,

Could you explain what triggers these errors? Are you developing an app and making calls to our REST API or SDK? I want to understand if this is related to an app built on top of our platform, or if you just started seeing these errors when working on your Miro board.


Do you see this problem with all the images in your board, or only certain images? Were these images added manually or through the API/SDK?


Please let us know if this issue is still happening for you and if there is a way to reproduce it. 


Kind regards.



Developer Experience team

Hi Daniela,


I’m not developing anything or making any requests myself, I’m just trying to use a Miro board and these requests must be ones made by the board page. The issue is with all images on any Miro board I’ve viewed recently. I used to be able to see images and it started out of the blue.

When it first started, I’ve tried dropping off the VPN I was on and using an incognito window but nothing made a difference (which I guess I expected with it being CORS related). I also haven’t made any changes to Chrome recently other than just updating the browser itself and trying FF or Edge also didn’t seem to make a difference (with the same expected result).


Kind regards,



Userlevel 7
Badge +5

Hi @philip.bushnell,

It seems to be a support issue, so I’ll convert your comments into a support ticket. The team will get back to you via email. 

Thank you Marina. :relaxed:

I too facing same issue

To help others - I recently discovered that I was getting certificate issues in other places too and the issue was actually with the Cisco Umbrella Agent preventing valid authentication. Manually stopping the following service allowed everything to work again.



Userlevel 2
Badge +3

getting cors errors too 


Access to XMLHttpRequest at '' from origin '' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource.


started getting these today all of a sudden, was able to make requests without any problem until now, weirdest thing is that the request still goes through 60% of the time

I also started getting those. Still using same browser, same OS , nothing has changed - except now I cannot use Miro boards at all. Dashboard though loads OK.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at (Reason: CORS request did not succeed).

Same error here! in all browsers! Dashboard loads fine.